Linux General

Last reply by 08-17-2020 Unsolved
Start a Discussion
2 Jasper
2 Jasper

ACPI BIOS Error (bug): AE_AML_PACKAGE_LIMIT, Index (0x0000000FF) is beyond end o


I've got a Dell G3 (3579) bought new with an Ubuntu 16.04LTS version installed.

It worked flawlessly, but I've to upgrade it to 19.10 version and next to 20.04LTS. As you may know, Dell inhibited distributions upgrades, but this is easy to bypass. So I upgraded to 18.04 LTS and then to 19.10.

Since then, I've got this acpi error :

ACPI BIOS Error (bug): AE_AML_PACKAGE_LIMIT, Index (0x0000000FF) is beyond end of object (length 0x11) (20190703/exoparg2-393)

When I do some disk activity (like during a backup) the machine freeze, mouse cursor stopping and machine becoming unresponsive for many seconds. This happens when iowait is above 25% ... So very annoying.

I tried, first, to upgrade the BIOS to the latest version, but to no avail.

I searched all that I could without luck.

So all the help I could get will be appreciated and thanked !

Thanks a lot in advance for your help.

Stay safe.

Replies (17)
3 Silver

Seems bios has a bug related to ACPI

Until Dell fixes this with a BIOS update (they may not if machine is old) my first move would be to ask for help on Ubuntu's forums. Perhaps some parameter at boot to the kernel can fix this. Or some config in kernel modules related to ACPI.


Thank you for answering me.

I've tried to ask the question on Ubuntu French forums but got no answer. So if you know a place where I could get some answer, I would be very glad to hear it from you !

As per Dell, I doubt it will be fixed one day, given the poor support they offer for the operating system they deliver the machine with.

Thank you very much for your answer !

Best regards.


I got the same error in my kernel dmesg.

Doesnt seem to have any bad effect on the machine or Ubuntu but it's something that can either be fixed in the machine's firmware or at the kernel sources. It might be a problem in how the kernel parses the ACPI content and not the firmware itself.


Been checking in more detail on my machine and it seems quite harmless.

When the ACPI data is parsed, each entry in the tree reports its size and then the parser will report to the log that it has found less items than reported. It is not an error, more of a warning. It means that the problem is inside the Dell bios/firmware, and harmless.

If it was something like AE_NOT_FOUND that would be more problematic.

Unless you got something else than PACKAGE_LIMIT you should be fine.


Thank you for your answer.

If I suppress PACKAGE_LIMIT errors from the logs, I still get some trouble :

ACPI Error: Aborting method \_SB.PCI0.SPI1.FPNT._CRS due to previous error (AE_AML_INVALID_RESOURCE_TYPE) (20190703/psparse-529)
ACPI Error: Method execution failed \_SB.PCI0.SPI1.FPNT._CRS due to previous error (AE_AML_INVALID_RESOURCE_TYPE) (20190703/uteval-68)
ACPI Error: Aborting method \_SB.PCI0.SPI2.FPNT._CRS due to previous error (AE_AML_INVALID_RESOURCE_TYPE) (20190703/psparse-529)
ACPI Error: Method execution failed \_SB.PCI0.SPI2.FPNT._CRS due to previous error (AE_AML_INVALID_RESOURCE_TYPE) (20190703/uteval-68)

ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20190703/nsarguments-59

And a lot of errors every time I hit the brightness keyboard buttons <Fn><F11> or <Fn><F12> which I know are "harmless"...

So I would like to get your opinion of these errors as well...

Thanks a lot in advance for your help !

Have a nice day and stay safe !


First you need to report this to Dell

I have seen this in the Github dedicated to the firmware upgrade tool. Maybe they can give us advice or they have a contact @Anonymous ?


Report this to Dell ?

I would if I could ! When you phone the French Dell support about _anything_ they want you to test under Windows before even accepting your call.

Or they say that the software you bought your device with is unsupported and you are on your own...

So I thought I could ask the Dell Community hoping that Dell was listening as other makers do in their community to get a hint at how their products are perceived by their customers.

Apparently, this is not the way Dell is running the show. And yes, I'm on my own.

And if you look at the repo Dell is "maintaining" for Linux, you'll see it is no more maintained. So I thought the patches needed to make the Linux Kernel and the Dell hardware had made it's way into the mainstream kernel (as Intel or HP or Lenovo do) but apparently it is not the case.

So if, by any chance, you have a way to make Dell aware of bugs in their software/machines, I would be delighted to know how to report it !

For now, I'm so vastly disappointed.


Go ask on the Linux kernel mailing-lists.

Perhaps someone from Dell is reading those. That's where kernel work is discussed.

I dont view support people as very competent, sorry. They are most of the time reading scripts on a screen, some are good, most are not. And if you talk of anything but Windows their incompetence shows.

Keep it to US people for anything serious and technical. I would try the mailing-lists for kernel work.


So, here i am again for an update.

Got a private message from a Bot asking if I wanted to get help from a Tech Expert. I aswered "yes" and got another Bot asking the very same question. Answered yes, also, and got another question about the same subject. Maybe I did something wrong ?

Anyway, a couple of days later i got an answer, and I quote : "

Hi Georges,

Please go to below steps provided

  1. Restart the computer.

  2. Press and hold the CTRL key + ESC key on the keyboard until the BIOS Recovery page appears.

  3. On the BIOS Recovery screen, select Reset NVRAM (if available) and press the Enter key. Select Disabled and press the Enter key to save the current BIOS settings.

  4. Select Recover BIOS and press the Enter key to start the recovery process.

also you can visit the below link for further clarification

and confirm. Thanks".


I tried, but <CTRL><Esc> does nothing on a Dell G3 3579. So I answered this. And asked what was the rational for this BIOS reset.

You know what ? I got a Bot asking me if I wanted a Tech Expert look at my problem....

Of course, I answered yes.

A couple of hours after, i got another message "

Hi GeorgesGiralt,

<ctrl><esc> trick for BIOS recovery option.also it is behind the operating system.


Also suggest you go below link follow page 99 for BIOS Flash "

So I wonder why they ask me to recover or flash the BIOS on this machine. I _already_ have the latest BIOS available and I bet, flashing it again won't solve anything.... if the utility allows it.

I wonder if I need a user manual to use the community support from Dell ? Or if something is broken at Dell ?

I still have my problems. They are not getting better. And no one at Dell seems to care. I though a Tech Expert could have a way to ask people at Dell or could have privileged contact at Dell; I was wrong.

I wonder what is the purpose of all this, if nobody listen ?

Have a nice and bright day and stay safe.

Latest Solutions
Top Contributor