Linux General

Last reply by 04-23-2019 Solved
Start a Discussion
Not applicable

D3100 Docking station for Ubuntu 14.10 (XPS13 2015)


I recently purchased the new XPS13 (2015 model) and a D3100 Docking station. The main reason for choosing a Dell laptop is because of project sputnik and their fantastic linux support. However, the docking station does not work with Ubuntu 14.10 (or any other distros I've tried). The USB, Ethernet, Sound etc. works fine, the displays does not however, none of the ports. This is quite bad as I paid a lot of money for this docking station just because it had multiple monitor support. Dell does not state anywhere on their webpage that the display does not work with this docking station when running Linux.

Does anyone know if dell is working on this issue or is it DisplayLink which is solely responsible to fix this?


Replies (14)
2 Bronze
2 Bronze

I managed to get it running, sort of.

Unfortunately it was terrible slow, somehow the USB connection is too slow to update the screen fast enough. So I gave up and used the HDMI cable again.

2 Bronze
2 Bronze

Hello Kjeld Flarup,

Even using USB 3.0 was the video streaming slow?

Gbtw, were you slow too?

I need two independent monitors connected to the notebook, nowadays without any device, I can connect only 1 monitor to the HDMI output, and to have two independent screens, but I would need for what I am planning on at least one screen, 3 independent screens counting with the own notebook.

Searching the internet I found on "" a product that claims to do what I need, but I'm giving preference to a product indicated by DELL itself.

The product in question that I found is this:

"UGA USB 3.0 Multi Display Adapter HDMI DVI Graphic Dual Monitor Converter"


XPS15 9560 (i7-7700Q) with Ubuntu 17.10.

Using latest drivers for D3100 (supports 17.04 and 16.04) works fine with one flaw:

log-in screen enters an infinite loop, i.e. click user, enter pwd, click user, enter pwd, etc.

To solve this, had to restart gdm when on the login window:

  1. CTRL+ALT+F3
  2. Login via the terminal.
  3. sudo service gdm restart
  4. Login via the UI.

This may be caused because my HDD was encrypted and a password is requested during boot when (presumably) the DP ports are still unavailable.


Currently trying the d3100. 



Not Working:





I've checked the displaylink support forums with no answers on any of the user submitted posts. I'm hoping to see a better show here as I can't find a phone number to call to speak with a representative, even a bad one.


On a Dell XPS 13 (9360) with Linux Mint 19.1 Cinnamon (Ubuntu 18.04 based) with driver version 5.1 (19 Feb 2019)

HDMI is working (after reboot).


USB and Ethernet have been reported to work earlier already:

So most things should work fine now.

Latest Solutions
Top Contributor