Highlighted
1 Copper

Dell 7040 Linux install issues

I managed to install Ubuntu 20.04 on my Dell 7040 and had it run fine for a week until mouse and keyboard input would drop out after a few mins of inactivity. Have found no resolve to the issue so tried to install other distros but cant even get them to boot. With Manjaro the live usb fails after "tlp startup/shutdown" every time time with free/non-free drivers and nomodeset parameter. Have tried fedora and kubuntu and usually get grub screen but immediately fail on startup from live usb. Secure boot is disabled and fast boot set to thorough. I have tried both uefi and legacy but still no luck. Any help would be greatly appreciated!
0 Kudos
1 Reply
Highlighted
7 Thorium

Re: Dell 7040 Linux install issues

I managed to install Ubuntu 20.04 (Secure Boot + UEFI + MOK), Mint 20 (Secure Boot + UEFI + MOK) and Fedora 32 (Secure Boot + UEFI) on a OptiPlex 7040 micro with BIOS version 1.15.5 without any major issues. I have documented the install and BIOS settings. Check that your SATA Operation is AHCI.

https://www.youtube.com/watch?v=n8VwTYU0Mec

https://www.youtube.com/watch?v=G_LSWhBj30Q

https://www.youtube.com/watch?v=ldIXEBOTb4U

Dr Philip Yip
Tech Enthusiast and Author of the Unofficial Dell Windows Reinstallation Guide

Windows FAQs and OEM Downloads


#IDoNotWorkFor Dell
0 Kudos