Linux General

Last reply by 08-24-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Dell Latitude 5420 / 5520 S3 Suspend (deep sleep) not working on Ubuntu 21.04


I just purchased the latest Latitude 5420 and I cannot get suspend to RAM working. I use Ubuntu 21.04 with kernel 5.11. dmesg shows there is no S3 supported:

# dmesg | grep ACPI | grep support
[ 1.423483] ACPI: (supports S0 S4 S5)

In BIOS I have Sleep S3 specifically unblocked (I also tried to change it to ON):


I also tried to add mem_sleep_default=deep to GRUB kernel boot options and also to force via command line, but mem_sleep file is not editable:

$ cat /sys/power/mem_sleep
$ echo deep | sudo tee /sys/power/mem_sleep
tee: /sys/power/mem_sleep: Invalid argument

When suspending (via systemctl suspend or from GNOME menu -> Suspend) I see it goes to s2idle always instead:

[ 1144.616225] PM: suspend entry (s2idle)

I tried everything I could find on the Internet but I cannot get it to go to deep sleep.

Replies (16)
2 Bronze
2 Bronze


I've been troubleshooting this ever since I got this laptop back in March of this year, having the same results than you. Apparently Dell has hardcoded this somehow and unless they say the contrary, I'd assume this is how is going to play.

On Windows 10 it seems to work fine as I did some testing and it didn't drain my battery overnight as it does on Linux.

I'm running Debian 10 with kernel 5.10 

2 Bronze
2 Bronze

I reached to Dell support and they told me that they don't support S3 simply because Windows 10 may have BSOD after wake. They don't care about other OS and they don't give customers a choice.

I used Ubuntu only for testing, since 5420 if officially Ubuntu certified. Apparently certification doesn't mean anything, since the laptop looses its mobility and always have to be plugged to charger.

I also tried with Debian 11 bullseye and the situation is the same. Which is expected since S3 is blocked in on a low-level BIOS.

I also tested on Windows 10 and deep sleep is also not available there:


Dell should unblock S3 and let customers decide for themselves if they want to use S3 or not. We should also complain to Dell directly to get their attention.

2 Bronze
2 Bronze

Dell support also told me there is a registry key that can enable S3 in Windows but I was discouraged to try. It means there is a way to unblock S3 in Linux as well.

2 Bronze
2 Bronze

Hi, I'm also struggling with this one. I just noticed that the Live USB stick (Linux Mint) does seem to be able to Suspend!

I had only tested with the installed version of Mint, but with the Live USB loaded I can Suspend and wake the laptop (Dell 5490) again and again! Is there someone who can reproduce this? Might this be an opening to make it work with the installed version? I hope someone knows how to make this work. 

2 Bronze
2 Bronze

@jellexcould you please check it really goes into deep sleep? Before entering sleep run:


sudo dmesg -w | grep PM:


after resuming from sleep you should see this:


[164594.621487] PM: suspend entry (deep)
[164595.303880] PM: Saving platform NVS memory
[164595.332682] PM: Restoring platform NVS memory
[164596.536893] PM: suspend exit



Thanks for your suggestion. I already replaced the laptop with another one, so I stopped testing. I still have it, so I tried it out. Strange thing is that now suspend also doesn't come back on the Live USB... So, sorry that won't help troubleshooting.

I'm now using a self built barebone laptop, but even that one struggles with S3. Hibernate does work smoothly.


This is nice input that confirms what I was suspecting. Good job dell, its time to get back to lenovo... 

2 Bronze
2 Bronze

Just tested this on a Latitude 7420 i7 on windows 10 issuing powercfg /a 

The output is the same than for Latitude 5420. 

2 Bronze
2 Bronze

I also have this issue with the Latitude 5420, deep sleep is disabled. Looking at the BIOS settings, it should be enabled. I'd like to know when we can expect a bios update for this or I'll have to send this back as it's unacceptable to have a laptop that can't sleep.

Latest Solutions
Top Contributor