Linux General

Last reply by 08-24-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
10243

Dell Latitude 5420 / 5520 S3 Suspend (deep sleep) not working on Ubuntu 21.04

Hello,

I just purchased the latest Latitude 5420 and I cannot get suspend to RAM working. I use Ubuntu 21.04 with kernel 5.11. dmesg shows there is no S3 supported:

# dmesg | grep ACPI | grep support
[ 1.423483] ACPI: (supports S0 S4 S5)

In BIOS I have Sleep S3 specifically unblocked (I also tried to change it to ON):

svlasov_0-1626645647220.png

I also tried to add mem_sleep_default=deep to GRUB kernel boot options and also to force via command line, but mem_sleep file is not editable:

$ cat /sys/power/mem_sleep
[s2idle]
$ echo deep | sudo tee /sys/power/mem_sleep
deep
tee: /sys/power/mem_sleep: Invalid argument

When suspending (via systemctl suspend or from GNOME menu -> Suspend) I see it goes to s2idle always instead:

[ 1144.616225] PM: suspend entry (s2idle)

I tried everything I could find on the Internet but I cannot get it to go to deep sleep.

Replies (16)
2368

There are actually some people who managed to have their recent Dell laptop work by patching the ACPI DSDT table. You can find more information here

2 Bronze
2 Bronze
1940

Hello,

I just got my work laptop Latitude 7520 with having same problem with missing S3 support. The default activated 's2idle' drained full battery within 24 hours to 0%. Bios version is 1.12.2 and block S3 mode is disabled by default. I have Manjaro installed and tried to patch ACPI DSDT table but that didn't work as well. To me this is unacceptable that paying more than 2000 Euros and can't even get Laptop to suspend to RAM. How am I suppose to take laptop daily back from work if it can't sleep properly and consuming too much power.

I regret changing from Lenovo to Dell. Their keyboards are far superior even on 14 inch laptops. The German keyboard on Latitude is miserable: too small enter key, arrows up & down keys and missing page up and down keys. I figured that I can enable these key with Fn+Arrow which is not a very user friendly solution.

Please Dell fix the issue with S3 state in next BIOS version or tell us how to fix it on Arch Systems. That is one major unacceptable issue.

 

2 Bronze
2 Bronze
1853

Same issue here.

No deep sleep available. Battery goes to 10% overnight.

Dell Latitude 5520 , Linux kernel 5.10

The ACPI DSDT fix doesn't fully apply to this model.

2 Bronze
2 Bronze
1799

Has anyone successfully patched ACPI for the 5420? A bit afraid to brick something as this is a work laptop

2 Bronze
2 Bronze
1410

Just got into my hands a new generation Latitude 5530 with 12th gen Intel CPU. 

Issue remains the same, output from powercfg /a on Windows remains exactly the same.

What is really "funny" from this situation is the fact that if I go to the BIOS' of both the Latitude 5420 as of this Latitude 5430 standing next to me, I find an option in "Power" section called "Block Sleep", this option literally says that if you as a user wish to block Deep Sleep S3 you can enable, but it is OFF and still I get S3 blocked... incredible. 

Dell nor Intel seems really interested into listening to the community, it's a pity the decisions they are taking and forcing the users to take. 

In the meantime, I've purchased a Lenovo T14 Gen2 AMD for my professional activities and I couldn't be happier with it running Linux. Byebye Dell, hope this is my last post "complaining" about basic tech and functionalities that a poweruser's laptop should have. 

1410

Hello, I see you are looking for technical assistance. If you need our help, you can start a private/direct message with us and we will be happy to assist you.


#IWork4Dell
Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".

1194

I have the same problem with Latitude 5530.

One flag in the BIOS will solve this issue. It's not a big deal for DELL.

It does not matter, every year I will ask them for a new battery, I have a 3 year warranty.

When I buy a Dell product I expect evolution not regression.

Amazing this story. I am disappointed with DELL.

Latest Solutions
Top Contributor