1 Copper

Re: Dell xps 13 9370 Webcam support / now working?

Jump to solution

Confirm the 1.5.1 version of BIOS fixes the deep sleep issue, now I am a happy Dell customer. 

0 Kudos
1 Copper

Dells official solution

Jump to solution

Hi all, I'd stopped following this thread a while back to avoid any further dissapointment. I decided today that I had Dell premium support for a reason and decided to phone, shockingly I wasn't on hold for too long before a chap answered and set about asking me all the same questions I'd already answered previously... always the way.. Anyway he asked what I'd tried, I said I'd played previously and had it working for a few days then it stopped again and I couldn't be bothered to trawl through my history to find a guide and gave up.. A few seconds on hold and I'd been sent and email with instructions, I opened it to see but a simple apt command and to reboot, I was feeling pretty doubtful but the chap seemed confident and wanted to stay on the phone so I ran the command, rebooted and went to open cheese.. I'd bloody deleted it, moments later, we're installed again and it was only bloody working.. I was a bit shocked, slightly happy and keen to share the steps so here I am.. Not sure if this was posted on previous pages, I clicked for the answer and scrolled through this page but didn't find anything the same.. Here's the instructions from Dell;


Greetings from Dell Technical Support Team.

1. Run the following in Terminal: sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04
2. Reboot the system.
3. To test the fix, install and run the Cheese camera app. 

NOTE: If you do not have Cheese installed, you can install it using this command in terminal: sudo apt-get install cheese.

0 Kudos
1 Copper

Re: Dells official solution

Jump to solution

Anyone else having issues with quality/low res images of the webcam, but it always works?

I can set the video capture resolution via `v4l2-ctl --set-fmt-video=width=1280,height=720,pixelformat=0` , but when I open cheese, the resolution goes back to 640x480 and the pixel format changes from MJPG to YUYV.

If I run a boot drive with Ubuntu 16.04 this doesn't happen. I'm running 18.04, which I installed to dual-boot with the windows 10 that came with this new machine.

1 Nickel

Re: Dell xps 13 9370 Webcam support

Jump to solution

Should the Infrared Camera also work in Ubuntu 18.10?

The RGB web cam appears to work well.  However, the infrared camera is failing for me.  Cheese does not detect it.  And, fswebcam fails to grab pictures from it.   Syslog reports:

[  418.850697] ------------[ cut here ]------------
[  418.850700] Unknown pixelformat 0x00000000
[  418.850767] WARNING: CPU: 4 PID: 4256 at drivers/media/v4l2-core/v4l2-ioctl.c:1297 v4l_fill_fmtdesc+0xe71/0x1220 [videodev]
[  418.850768] Modules linked in: thunderbolt rfcomm ipt_MASQUERADE nf_conntrack_netlink nfnetlink xfrm_user xfrm_algo iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 xt_addrtype iptable_filter bpfilter xt_conntrack nf_nat nf_conntrack libcrc32c br_netfilter bridge stp llc overlay aufs ccm arc4 cmac bnep nls_iso8859_1 snd_hda_codec_hdmi joydev snd_soc_skl snd_soc_skl_ipc snd_soc_sst_ipc snd_soc_sst_dsp snd_hda_codec_realtek snd_hda_ext_core snd_soc_acpi snd_hda_codec_generic snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel snd_hda_codec snd_hda_core dell_laptop snd_hwdep snd_pcm intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp ath10k_pci dell_wmi snd_seq_midi dell_smbios snd_seq_midi_event dcdbas ath10k_core kvm_intel snd_rawmidi kvm ath irqbypass snd_seq mac80211
[  418.850831]  intel_cstate snd_seq_device intel_rapl_perf snd_timer snd input_leds dell_wmi_descriptor wmi_bmof serio_raw btusb intel_wmi_thunderbolt btrtl btbcm uvcvideo cfg80211 btintel soundcore videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 bluetooth rtsx_pci_ms videobuf2_common memstick videodev mei_me ucsi_acpi idma64 typec_ucsi processor_thermal_device media ecdh_generic hid_multitouch mei virt_dma intel_pch_thermal intel_soc_dts_iosf typec intel_hid int3403_thermal int340x_thermal_zone int3400_thermal sparse_keymap acpi_thermal_rel acpi_pad mac_hid sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 algif_skcipher af_alg dm_crypt hid_generic crct10dif_pclmul crc32_pclmul ghash_clmulni_intel pcbc i915 rtsx_pci_sdmmc aesni_intel i2c_algo_bit drm_kms_helper aes_x86_64 nvme
[  418.850896]  crypto_simd cryptd syscopyarea glue_helper sysfillrect sysimgblt psmouse fb_sys_fops drm nvme_core rtsx_pci i2c_i801 intel_lpss_pci intel_lpss i2c_hid wmi hid pinctrl_sunrisepoint video pinctrl_intel
[  418.850920] CPU: 4 PID: 4256 Comm: v4l2-ctl Tainted: G        W         4.18.0-15-generic #16-Ubuntu
[  418.850922] Hardware name: Dell Inc. XPS 13 9370/0F6P3V, BIOS 1.6.3 11/04/2018
[  418.850932] RIP: 0010:v4l_fill_fmtdesc+0xe71/0x1220 [videodev]
[  418.850933] Code: c6 2b 63 49 c0 e9 46 f2 ff ff 48 c7 c6 d4 5e 49 c0 3d 4d 54 32 31 0f 84 34 f2 ff ff 89 c6 48 c7 c7 8b 6b 49 c0 e8 51 fe 60 ee <0f> 0b 41 80 7c 24 0c 00 0f 85 36 f2 ff ff 41 8b 44 24 2c 49 8d 7c 
[  418.850986] RSP: 0018:ffffb605c3c23c60 EFLAGS: 00010286
[  418.850989] RAX: 0000000000000000 RBX: ffffb605c3c23d88 RCX: 0000000000000006
[  418.850991] RDX: 0000000000000007 RSI: 0000000000000082 RDI: ffff8a912e5164b0
[  418.850992] RBP: ffffb605c3c23c70 R08: 0000000000000001 R09: 00000000000004a0
[  418.850994] R10: 0000000000000004 R11: 0000000000000000 R12: ffffb605c3c23d88
[  418.850995] R13: ffffffffc084d9a0 R14: ffff8a90dfb75c00 R15: 0000000000000000
[  418.850998] FS:  00007efe98f4b740(0000) GS:ffff8a912e500000(0000) knlGS:0000000000000000
[  418.851000] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  418.851002] CR2: 0000564635b8f500 CR3: 00000004574ee004 CR4: 00000000003606e0
[  418.851004] Call Trace:
[  418.851016]  v4l_enum_fmt+0x74/0x110 [videodev]
[  418.851025]  __video_do_ioctl+0x138/0x2d0 [videodev]
[  418.851034]  video_usercopy+0x1a6/0x630 [videodev]
[  418.851042]  ? v4l_fill_fmtdesc+0x1220/0x1220 [videodev]
[  418.851052]  video_ioctl2+0x15/0x20 [videodev]
[  418.851059]  v4l2_ioctl+0x49/0x50 [videodev]
[  418.851066]  do_vfs_ioctl+0xa8/0x620
[  418.851071]  ? vfs_write+0x17f/0x1b0
[  418.851075]  ksys_ioctl+0x67/0x90
[  418.851080]  __x64_sys_ioctl+0x1a/0x20
[  418.851085]  do_syscall_64+0x5a/0x110
[  418.851090]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[  418.851093] RIP: 0033:0x7efe994f23c7
[  418.851093] Code: 00 00 90 48 8b 05 c9 3a 0d 00 64 c7 00 26 00 00 00 48 c7 c0 ff ff ff ff c3 66 2e 0f 1f 84 00 00 00 00 00 b8 10 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 99 3a 0d 00 f7 d8 64 89 01 48 
[  418.851147] RSP: 002b:00007ffc80725eb8 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[  418.851150] RAX: ffffffffffffffda RBX: 0000000000000003 RCX: 00007efe994f23c7
[  418.851151] RDX: 00007ffc80725f60 RSI: ffffffffc0405602 RDI: 0000000000000003
[  418.851153] RBP: 00000000ffffffff R08: 00007efe98f4b740 R09: 00007ffc80725dd7
[  418.851154] R10: 000056463596f28b R11: 0000000000000246 R12: 0000000000000001
[  418.851156] R13: 000056463596bee4 R14: 000056463596bee5 R15: 00007ffc80725ed0
[  418.851160] ---[ end trace 5c1a1c0aadeb5a14 ]---


Any thoughts?

Tags (2)
0 Kudos
1 Copper

Re: Dells official solution

Jump to solution

I'm also getting a maximum resolution of 640x480 on Arch Linux with BIOS version 1.8.1.

0 Kudos