Highlighted
svinqvmraka
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

Yeah, I regret not using the preinstalled version of ubuntu for a few days. Bad thing is I almost instantly wiped the disk and installed windows and then the latest ubuntu, so i have no idea if the preinstalled one worked fine. I hoped there is an OEM, dell made image of ubuntu for dell laptops, that works as it is supposed to work, but apparently there isn't. Too bad really, I find windows 8 terrible and linux is practically unusable right now.

I guess the catch is, it says 'Ubuntu certified(preinstalled only)'. Which again makes me think there is something in the preinstalled OS that makes it work properly.

Reply
Highlighted
svinqvmraka
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

Hello again, status update:

I updated the BIOS to the latest version(A06 I think, mine was A02) and disabled the Radeon GPU with vgaswitcheroo(in ubuntu) and I think it works okay now. Fan is not constantly running, temperatures are normal. I haven't tested the battery life yet, but I think it will be better.

For anyone that has the same problem, here's what I did:

1. Updated my BIOS.

2. To disable the radeon card(source: askubuntu.com) -

chmod -R 705 /sys/kernel/debug

then:

chown -R $YOURUSERNAME:$YOURUSERNAME /sys/kernel/debug/vgaswitcheroo   (where $YOURUSERNAME is your user name)

and finally:

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch   (this will turn off your currently unused card. This is normally the discrete one.)

You'll be using the intel graphics only but I think they'll do the job. They do for me at least. I'm not entirely sure this works, but it's definitely better. Let's hope for better times when 'ubuntu certified' devices will actually work with ubuntu without the user disabling parts of his computer. I love the machine as such but my next laptop probably won't be a DELL.

Reply
Highlighted
Wrezter
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

Hi there!

I've tried your way with the updated BIOS and the vgaswitcheroo method. Unfortunatelly it doesn't work. 😕

My BIOS was already updated, so I've installed a clean Ubuntu 12.04 LTS 64bit and switched graphic card with vgaswitcheroo. (Before I've tried this method with the previous BIOS versions, it didn't work.)

After I switched the Radeon GPU off, I checked the switch file and it was really off. I've waited some minutes, but the fan didn't stop. Later it stopped, but when I try to open either a web browser, it was on full speed again.

However I've called the local (Hungarian) Dell technical support and they said, that it's a known problem and they are working on the fix. This was the first "usable" official answer from Dell to this problem.

All we have to do is wait. I hope so.

It would be great, if here at this forum Dell would make some reply on this problem too.

Keep in touch,

Wrezter

Reply
Highlighted
svinqvmraka
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

Hey,

Yeah it's not a perfect solution but, at least for me, it's better than with both the GPUs working - if you have installed lm-sensors and type 'sensors' in the terminal, you can see how hot the ATI GPU gets and for me that was part of the problem. The fan still runs more than it should but it's bearable now. It also resets after reboot, so it has to be a script, run at startup if one wants to avoid typing the commands every time.

"However I've called the local (Hungarian) Dell technical support and they said, that it's a known problem and they are working on the fix. This was the first "usable" official answer from Dell to this problem."

That's great news, let's hope they come out with a fix soon enough.

cheers, svinqvmraka

Reply
Highlighted
clempe
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

Has somebody found a fix already?

Reply
Highlighted
stillblue
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

You may want to install LXDE from the repositories (synaptic) and switch to it during your log-in or end your session and switch to it. It if far less CPU hungry and should cool down your system considerably and extend battery life.

Reply
Highlighted
svinqvmraka
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

The problem was not CPU usage, the laptop has an Ivy bridge i5, it can handle unity. The problem is that linux doesn't like the intel/ati gpu combo and for some reason the discrete card is heating up quicky(even though it should pretty much not work, when it's not needed), which turns the fan on so it can keep up with the heat, which uses a lot more battery.

Disabling the discrete gpu did it for me - no constant fan running, normal battery life.

Reply
Highlighted
Wrezter
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

Hello svinqvmraka,

I would like to ask you to tell me in details, how did you do this discrete card disabling with vgaswitcheroo. I can echo OFF to the switch file and then it says that the discrete card is off, but the fan is running constantly. Should it go down? I think the problem is that on every boot the system starts with the default options (DIS ON). How did you achieve that the fan goes down and the card is really off? Do you use any method to apply these settings at boot time? I've tried to use the rc.local file, but somehow it didn't work. Please give me a full instruction from the very beginning. By the way, I called the Hungarian Dell Technical Support again (after 1 month) but they can't tell me any good news about this problem.

Thank you,

Wrezter

Reply
Highlighted
svinqvmraka
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

Hey wrezter,

I did what I posted a few posts back - just run the three commands:

1.    chmod -R 705 /sys/kernel/debug  

2.    chown -R usrname:usrname /sys/kernel/debug/vgaswitcheroo    (replace 'usrname' with your username)

3.    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

First thing - make sure you run all those with sudo - the chown and chmod commands need root access.

Second - For easy running, i created a bash script that runs those three commands all at once. Here is what my script contains:

#!/bin/sh
notify-send "Disabling ATI GPU"
chmod -R 705 /sys/kernel/debug
notify-send "chmod - rdy"
chown -R emo:emo /sys/kernel/debug/vgaswitcheroo
notify-send "chown - rdy"
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
notify-send "Disabled."
Where 'emo' is my name, you should replace it with your username.
What it does is running each command one after another and displaying a notification to see what is going on(you can change those, or remove them alltogether:))
paste this into an empty file and save it as something.sh(in my case I named it gpu.sh) and put it in your home folder.
Then when you start ubuntu, just type 'sudo sh gpu.sh' in the terminal and wait a couple of seconds.

To check if it is working okay, install the lm-sensors package(sudo apt-get install lm-sensors). After it is installed, type 'sensors' in the terminal. For me, when the discrete gpu is disabled,  the output of  'sensors' ends in something like that:
radeon-pci-0100
Adapter: PCI adapter
temp1: -128.0°C
Look at the last line - temp1: -128C. When I run sensors before disabling the radeon gpu, temp1 shows a real temperature reading - 30-40C. After I disable it, look like the sensors stops working and shows -128 degrees. That's how i check if it's working.

The rc.local autostarting is optional and I read it in the ubuntu forums but I haven't done it yet because I'm fine with running the script at startup.

I should say that after about a month of using ubuntu like that, I'm very happy with it. The fan runs sometimes, but by far not that often to be annoying, the temperature readings are great and if I put the laptop on my cooling pad, the fan is not working 99% of the time.
Battery lasts for about 4-4.5 hrs normal usage. Not as good as with windows, but still good enough for me.
Hope this works
cheers, svinqvmraka

ps. I did all that on ubuntu 12.04 at first and it worked perfectly fine. I've now installed the 13.04 beta 2(which is surprisingly stable and snappy btw) and it still works great.
Reply
Highlighted
Bergreat
1 Copper

Re: Inspiron 15-3521 DELL OEM Ubuntu image

Hello ,

any other solution, i have the same problem, and i tried many of version of ubuntu, opensuse, and fan still make noise.
it is stable only on windows, i want to know the drivers that you have installed both for intel and ati.

Best regards.
Reply