Highlighted
2 Bronze

Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

  I need to install ubuntu on 7490, but now it blocks by the intel RST mode. The disk can't be found when installing. As guide , i need to turn off 'RAID on', and swith disk mode to AHCI, but how to do that? i realy can't find related items from current 7490 bios. Who can support here?

62 Replies
Highlighted
5 Rhenium

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

Welcome to the Dell Community @bulaqi 

EDITED: Removed reference to wrong manual.

Best regards,

U2

HP EliteBook 8770w i7-3630QM 32GB
HP ZBook 17 G2 i5-4310M 16GB
HP ZBook 17 G4 Xeon E3-1505M v6 32GB
HP Color LaserJet M553dn 40ppm
0 Kudos
Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

Yes, i can find following options in another Latitude 7490 laptop    

  • Disabled
  • AHCI
  • RAID On: This option is enabled by default.

But, unfortunately, these options was changed in Inspiron 7490, only 2 options are left:   

  • Disabled
  • RAID On: This option is enabled by default.

I really can't undestand why dell change this key feature. Or there is another item in other place can do same thing?

Highlighted
Community Manager
Community Manager

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

bulaqi,

 

If you switch the storage interface to off can you then select disable and then switch it back on. What does it do?  Let me know. If this does not work I will need to contact a level 2 technician to see if this is by default and not able to change.

 

 

 

 



 

0 Kudos
Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

Jesse L,

   Thanks for your supporting.

   I did all steps as your suggestion: turn off interface -> disabled SATA controller -> switch interface back on.

   But, things still can't run lucky . Contents in 'Device information' show:

        Type = (none) and device = (none).

   During bootup,  a popup waring was shown:

            SupportAssist was able to identify a possible issue with your system..

           warning message: Hard Drive - Not installed.

    Boot OS from USB disk, system also can't find the hard drive.

 

 

Highlighted
Community Manager
Community Manager

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

bulaqi,

 

Start the computer and tap the F2 key to enter the bios. Choose the option to restore defaults ,save the changes and exit. Is th hard drive seen in the bios? Also, start the computer and tap the F12 key and choose to run the ePSA Diags. Post back with any failures.

 

 

 

 



 

0 Kudos
Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

I have restore the setting to 'Factory defaults' now. Still can't find the AHCI related items.

0 Kudos
Highlighted
Community Manager
Community Manager

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

bulaqi,

 

Unfortunately, I do not see the option in the bios to switch to AHCI. You can click here to download the online manual to view the setup options.

 

 

 



 

0 Kudos
Highlighted
7 Gold

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

@bulaqi  just out of curiosity, have you tried Disabled?  I'm wondering if Dell changed the meaning of that option so that "Disabled" now just means "RAID Mode Disabled", i.e. AHCI mode, instead of disabling the interface entirely. I would be surprised if they removed AHCI mode, but I could see them removing an option to disable the entire interface since that's not typically necessary.

0 Kudos
Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to AHCI?

Yes, i have tried the action to "Disabled". but unlucky, it does NOT means "RAID Mode Disabled", and use AHCI mode. It exactly disabled the disk fully, just as it's not plugged.

I' m so wondering and surprised this new 'FEATURE' now. and looking forward to finding a workaround.