Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

Hello,

I bought this computer in december from Dell obviously because Dell was known to have good compliance with Linux and specifically Ubuntu.

This limitation from the BIOS is really a shame. Why the hell don't you warn the buyer "hey guys, don't buy this, because its a windows only thing..."

You cant even boot any proper tool of your choice in order to make a backup, and I imagine bad issues if i later need to change things in my SSD configuration...

I had many computers (pc, mac, servers, embedded devices) in my life for professional or private use, I never had such limitations moreover for a ~1300€ laptop. We are not talking about a 30$ Raspberry Pi.

Please assume your position of "linux/ubuntu supporting vendor" and just work on a BIOS/Firmware that is supporting AHCI mode or provide the necessary drivers.

I hope it was not a deliberated choice from Dell to make such a limitation and that you will provide a workaround.

Thank you for your help and taking care of this situation.

Hugo

 

 

Highlighted
1 Copper

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

Same here, I too bought this laptop as I know Dell's history of support Linux but that "problem" is totally stupid... I infact know that Lenovo has had a laptop with the same "feature" and after some time patched it out. So please Dell do the same here, but not wait for years as I and presumably a lot of other people will sell this laptop if this won't be adressed in any way. This problem is just laughable, the only reason I see Dell doing this is that they got some money from Intel or sth like that...  

 

Maybe there is another way tho as with older models you could set BIOS settings like Dvmt and other ones with a patched grub (setup_vars https://github.com/datasone/grub-mod-setup_var) that would otherwise be inaccessible! I already extracted the vars with the universal IFR extractor. If someone can support me here, we might get this working without Dell. 

https://paste.gg/p/anonymous/1b29913a63ff41f586b6eb1523aa5463

0x78394 QuestionId: 0x415 equals value 0x0 {12 06 15 04 00 00}
0x7839A One Of: SATA Mode Selection, VarStoreInfo (VarOffset/VarName): 0x44, VarStore: 0x5, QuestionId: 0x416, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 7C 0B 7D 0B 16 04 05 00 44 00 10 10 00 01 00}
0x783AB One Of Option: AHCI, Value (8 bit): 0x0 (default) {09 07 7E 0B 30 00 00}
0x783B2 Suppress If {0A 82}
0x783B4 QuestionId: 0xB7E equals value 0x0 {12 86 7E 0B 00 00}
0x783BA QuestionId: 0xB47 equals value 0x0 {12 06 47 0B 00 00}
0x783C0 And {15 02}
0x783C2 End {29 02}
0x783C4 One Of Option: RAID, Value (8 bit): 0x1 {09 07 7F 0B 00 00 01}
0x783CB End If {29 02}
0x783CD End One Of {29 02}

That might be the right var but does it need to be 0x0? But that's the default value, why doesn't a BIOS reset fix it then? Anyone?

 

EDIT: 

m0dz1lla_0-1582395342731.png

AHCI really seems to be in the BIOS so there is no reason for it to be disabled!

0 Kudos
Highlighted
1 Copper

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

BIOS version 1.4.1, released on the 31/3/2020, still does not have an AHCI option.

Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

Also, to complete my previous post I tested the last BIOS update and It doesnt make the ahci option available.

I read some documentation about NVME and as far as as I understood, the nvme standard is supported by linux since many years (even on BSD). The problem here would be to simply disable the Intel raid layer that is useless on a single-drive computer.

Scientists made standards and norms, brands like Dell make it not compliant !

Can someone @ Dell answer about this point ? You are losing clients !

0 Kudos
Highlighted

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

I agree, they have lost me. I will return and never buy another Dell product

0 Kudos
Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

Hey guys May 1st update, someone's succesfully installed linux on his system. You can all do it too. There's a Linux distro that supports install with Raid on. So if you don't care about the distro, then go to Endless OS, make a USB stick and should be quick and easy.

If you're like me and wish you had ubuntu, then here's the link to the guy's post. There's a bunch of instructions but difficult to follow unless you're a guru. So anyone who actually succeeds in building an ubuntu image or does an install like the guy did there, then please post detailed instructions. Some parts of the instructions are not that detailed so not so easy for regulr people. Here: https://askubuntu.com/a/1232818/208345

 

Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

Update: Already compiled the linux Kernel with Endless OS patches. Trying to figure how to compile ubuntu with the custom kernel. Fingers crossed but should have a working image soon. I'm busy so will try to get that out in the next week or so. 

 

No thanks Dell

Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

So I have been running ubuntu 20.04 for the 3 weeks. Sorry guys took a while to make this post but you can see the image on sourceforge is almost a month old. Will update this guide with more detailed instructions with time, but you have the general steps. (Talking about the bootloader copying bit). Stackoverflow will tell you how to mount the boot partition and copy stuff, then unmount.

All seems okay, just been lazy to post the guide, but for the brave hearts, here's the image

https://sourceforge.net/projects/ubuntu-raid/files/Ubuntu-Raid-5.60-7-generic/

 

After installing it you must fix the bootloader. So the instructions for doing that- I didn't document the commands to the last bit but I will post general instructions on how I did it. Rest assured, it's super easy and it is highly unlikely you will end up with a damaged windows boot

 

1. After installing with this cd, you have to still boot into the installer on pendrive not your harddrive

2. Don't waste time trying to autofix grub, it doesn't work. All instructions you will find online will waste your time.

3. Go to SuperGrub and download the standalone EFI image. 

4. Copy this image to anywhere on your boot partition

5. Reboot and enter BIOS settings

6. Add a boot option within the firmware, give it a name and for the image location, it will open a file picker, you can navigate to your boot partion from here and select the supergrub image you copied

7. (Optional) Can reorder your boot options so that this option it the first

SUCCESS

 

Note: - whenever you boot, supergrub always detects installed OS's on your system and provide a list you can select from. This means it is sort of bullet proof since it does this detection on boot (fast). Thus regardless of how many OS's you'd like to boot, they will always be autodetected and you don't have to change/fix your bootloader again.

 

Can boot into both windows and Ubuntu from this

 

For ubuntu, always select the 5.6 kernel from the boot options every time you are booting, that is the new kernel I compiled with the RAID fixes, the 5.4 won't boot.

 

8. On first boot, you want to pin the kernel version so that it is never updated on update check. Run `sudo apt-  mark hold 5.6.0-7-generic`

Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

The prospect of being able to run Ubuntu on Inspiron 7490 at last sounds amazing! I used dd command to copy "Ubuntu-Raid-5.60-7-generic/custom-dist.iso" to a usb stick and tried booted from it. Unfortunately I get this error:

'Could not open "\EFI\BOOT\fallback.efi": 14'

Also tried it with 'Safe boot' disabled, but same error.

0 Kudos
Highlighted
2 Bronze

Re: Inspiron 7490 BIOS: How to turn off intel 'RAID on', and swith disk mode to

Thank you so much @evroza , works great ! 
The superGrub works fine, I even did not messed my Windows setup.

Ubuntu and all my environment is working fine, I can now use my laptop as I intended.
The only thing wrong is that it's a laptop with "Prime" or "Optimus" graphics drivers due to Nvidia&Intel graphics, and I can't get Vsync with my nvidia driver (Open Xorg or nvidia sourced), and by following few tips to force vsync on prime laptops, I made Ubuntu unabled to boot. Had to reinstall Ubuntu 3 times each time I screwed it.

But anyway except this vsync issue, everything is working great. Thank you a lot.

0 Kudos