Highlighted
2 Bronze

Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

Hi,

I recently purchased an Inspiron 7591 laptop and although Ubuntu wasn't offered pre-installed I was told by Dell customer service that I would be able to install it fine myself, which I did. After installing ubuntu 19.10 the sound and microphone were not working. In the sound menu it had "dummy output", and nothing for input. Today I upgraded to Ubuntu 20.04 LTS and have found the same issues. 

While I have found a fix-around to get the sound working I don't have complete faith in it, and the microphone still does not function.  It would be nice if there was an official fix from Dell as I don't seem to be the only person experiencing this.

Any suggestions?

 

Labels (3)
9 Replies
Highlighted
1 Copper

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

It is probably a bug in Ubuntu 20.04. It affects Inspiron 1525 too.

0 Kudos
Highlighted
1 Copper

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

I have the same problem on Vostro 1458. What was your fix-around?

0 Kudos
Highlighted
2 Bronze

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

To get sound working (but not inbuilt microphone) this fix around worked for me: https://superuser.com/questions/1509312/sound-stopped-working-after-upgrading-to-linux-5-4-intel-hd-...

0 Kudos
Highlighted
1 Copper

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

There is an issue with microphone autodetection - I use the 3,5 mm 3 pin jack as AUX to my tower, but when I connect it, Kubuntu switches from Internal Microphone to Microphone and disables all output, and even worse, the tower randomly starts/stops brumming whatever I will set as microphone input until I set input to Internal Microphone and start playing something, then brumming stops.

When I use 4 pin jack with splitter to microphone and 3 pin output, suprisingly everything behaves the same (wrong) way (brumming + Kubuntu automatically switched to Microphone even when it is not connected).

I have no idea if it is some firmware/bios/OS issue, but probably ... I would blame Ubuntu for that.

I have Dell 7740,

cat /proc/asound/card*/codec* | grep Codec
codec Realtek ALC289

0 Kudos
Highlighted
1 Copper

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

For those of you who have Ubuntu, you have three options to fix this:

 

1.) Apply this patch and reboot: https://launchpad.net/~kaihengfeng/+archive/ubuntu/fix-lp1869819

 

2.) Else, enable 'Pre-released updates (focal-proposed)' under Developer options in Software & Updates. Update and reboot.

 

3.) Else, wait for the next PulseAudio update.

Highlighted
2 Bronze

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

Non of the above helped. 

 

Dell please fix this. This was supposed to be a certified Ubuntu HW. 

Highlighted
1 Copper

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

@mmmaaaattttt  Seems as of now they have certtified for ubuntu 18.04. not for 20.04. Hope it will solve soon,

Highlighted
2 Bronze

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

I tried 18.04 on 7591 .. Wifi doesn't work, sound doesn't work at all. 

on 20.04 Wifi works, but it's not stable. 

Not sure why this is listed as compatible with Ubuntu. 

 

 

0 Kudos
Highlighted
1 Copper

Re: Inspiron 7591 no sound or microphone after Ubuntu 19.10/20.04 install

Did you try updating the kernel? I updated to 5.8 and now mine is working fine. Hope this helps.

0 Kudos