Linux General

Last reply by 05-03-2008 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Linux driver for dell 1320c Printer

Recently my father purchased a dell 1320c printer which i then set up as a network printer here in my home, just the problem is I use Ubuntu 8.04 on both my desktop PC and my laptop, however, Dell does not seem to offer drivers for this particular printer for any OS other than Windows.  It was unexpected, seeing as Dell does offer Linux (Ubuntu even!) on some of their PCs and Laptops, yet they don't have drivers available for another of their products?  I also tried the one fix i found for it (using fujitsu foomatics drivers for the printer), however, i had no luck with that.  Anyone have a working fix, or have a driver available somewhere?


Thanks in advance,


Replies (2)
3 Argentum

This is fron a web-friend Jeff Koenig's website ( -- it is written for distros that use rpm (well,'s rpm4 ;-) 

Anyway, you can follow these just get the non-rpm/source file 


Dell 1320c color laser printer Linux install
Updated: 4/19/2008

Note: this install was done on a Fedora 8 Linux installation.

Follow printer initial hardware instructions to setup printer hardware and insert paper in printer tray.

Connect printer to network with dhcp server (cable router, etc...).

Power on printer.

When printer is ready, press and hold printer "Continue" button to print settings pages to get printers DHCP assigned IP address.

To configure the printer, connect to and login to it via:
http://x.x.x.x/ where x.x.x.x is your printer's IP address.
Default printer username: admin
Default printer password: (blank/none)
Change the printer to use a static IP address instead of DHCP address.

The Dell 1320c seems to work with the Fuji Xerox DocuPrint C525A printer Linux driver:
Fuji Xerox DocuPrint C525A printer web site:
Fuji Xerox DocuPrint C525A printer Linux driver downloads:
Direct link to Linux driver file:
Direct link to Linux User Guide:

Install the Linux driver:
rpm -Uvh Fuji_Xerox-DocuPrint_C525_A_AP-1.0-1.i386.rpm

Configure the printer:
Click on "System - Administration - Printing"
Click "New Printer"
Click "LPD/LPR Host or Printer"
Enter the "Hostname" as "x.x.x.x" where x.x.x.x is your printer's IP address.
Exampel: ""
Click "Forward"
Select "FX"
Click "Forward"
Select "DocuPrint C525 A-AP"
Click "Forward"
Enter "Dell1320c" for "Printer Name".
Enter "Dell 1320c color printer" for "Description".
Click "Forward"
Click "Apply"
Verify "Device URI:" is "lpd://x.x.x.x" (based on your IP address of the printer)
Click "Options Installed" and for "Optional Tray Module" select "250 Sheet Feeder".
Click "Printer Options" and change "Paper Source" to "Tray 1 (250 Sheets)"
Click "Apply".
Click "Settings" and then click "Print Test Page".

Other Notes:
Default printer username: admin
Default printer password: (blank/none)

To manage the CUPS printing system on your PC:

Fuji Xerox DocuPrint C525A printer Linux driver installs these files:
# rpm -qpl Fuji_Xerox-DocuPrint_C525_A_AP-1.0-1.i386.rpm


Message Edited by PhillyFloyd on 05-03-2008 08:48 AM
2 Bronze
2 Bronze

Thanks for that, but I've already tried it, didn't work for my network set up (seemed to work, the light would go green, but it wouldn't print).   I'll give it another try though, getting tired of going upstairs to plug in a USB cable to the laptop so i can print to the HP printer i've got up there.  On a side note, you can convert rpm files to .deb using alien.


*EDIT* looks like i forgot to change what paper tray it was meant to use, woops.  Thanks, that solution did work.

Message Edited by lswest on 05-03-2008 08:11 AM
Latest Solutions
Top Contributor