Highlighted
kjs2001
1 Copper

Same EMC LUNs with different SCSI device names on different systems

Sorry if this is the wrong forum, but 'Storage' seemed more hardware-oriented.

I have RHEL 5.3 on 3 servers running Oracle RAC clusterware.  Qlogic HBAs to EMC Clariion using powerpath. 

Presented 1 new LUN in Storage Group visible to all servers.  Server RAC03, ran Qlogic scan, then 'powermt config', and 'fdisk emcpowerAA'. Repeated these steps individually for 5 more LUNs. 

Now all 6 LUNs are visible (in the EMC Storage Group) to all 3 servers, but not defined on RAC01 and RAC02.  I ran the Qlogic scan on 01 and 02, and the /dev/sdXX names are assigned 'down' instead of 'across':

RAC03:

        LUN --> --> --> -->
800 sddp sddq sddr sdds
801 sddt sddu sddv sddw
802 sddx sddy sddz sdea
803 sdeb sdec sded sdee
804 sdef sdeg sdeh sdei
805 sdej sdek sdel sdem

RAC01:

      LUN

800 sddp
sddv sdeb sdeh
801 sddq
sddw sdec sdei
802 sddr
sddx sded sdej
803 sdds sddy sdee sdek
804 sddt sddz sdef sdel
805 sddu sdea sdeg

sdem

Shown another way, LUN 800 on each server:

[root@rac01: tmp]# powermt display dev=emcpowerag

Pseudo name=emcpowerag

CLARiiON ID=APM00073401969 [PRODQARAC]

Logical device ID=60060160E2002700BE485F1B810CE011 [LUN 800]

state=alive; policy=CLAROpt; priority=0; queued-IOs=0

Owner: default=SP B, current=SP B       Array failover mode: 1

==============================================================================

---------------- Host ---------------   - Stor -   -- I/O Path -  -- Stats ---

###  HW Path                I/O Paths    Interf.   Mode    State  Q-IOs Errors

==============================================================================

   1 qla2xxx                   sddp      SP A2     active  alive      0      0

   1 qla2xxx                   sddv      SP B3     active  alive      0      0

   2 qla2xxx                   sdeb      SP B2     active  alive      0      0

   2 qla2xxx                   sdeh      SP A3     active  alive      0      0

 

[root@rac03: ~]# powermt display dev=emcpowerad

Pseudo name=emcpowerad

CLARiiON ID=APM00073401969 [PRODQARAC]

Logical device ID=60060160E2002700BE485F1B810CE011 [LUN 800]

state=alive; policy=CLAROpt; priority=0; queued-IOs=0

Owner: default=SP B, current=SP B       Array failover mode: 1

1 qla2xxx                   sddp      SP A2     active  alive      0      0

   1 qla2xxx                   sddq      SP B3     active  alive      0      0

   2 qla2xxx                   sddr      SP B2     active  alive      0      0

   2 qla2xxx                   sdds      SP A3     active  alive      0      0

So, now each LUN has different underlying SCSI devices, and may have different emcpowerAA names (though I think I can fix that with 'emcpadm rename').

How do I get them consistent?  I'm not adverse to blowing things away and starting over, if it's clean. My proposal:

a) fdisk emcpowerAA1  > delete partition

b) remove from powerpath management ???

c) remove from Storage Group and rescan Qlogic

d) remove /dev/sdXX ???

e) remove from SG.  Then add each serially on each server.

And, of course, these are production servers, with other LUNs in use on the same HBAs.

Thanks for any help .....

 

Tags (2)
0 Kudos