Linux General

Last reply by 01-31-2019 Unsolved
Start a Discussion
2 Bronze
2 Bronze
35841

how to install linux on XPS 15 9570?

Hi, I should install linux in dual boot in my XPS 15 9570. What settings of the bios do I have to change over to the secure boot?

Replies (12)
2 Bronze
2 Bronze
35501

As an example, in the case of Ubuntu 18.xx in a dual boot configuration, download the Ubuntu image, flash it to a thumb drive (etcher makes this easy). Restart the laptop (leaving the newly flashed bootable drive in a usb port) and hit the F2 key as soon as the Dell logo appears. In the boot menu in the BIOS set the flash drive to be the first bootable device. Restart and the Ubuntu installer should load. In the case of that Linux build it pretty much does everything for you to make the system dual boot to include creating it's own ext4 partition. After installation the system will boot to a menu that lets you select Ubuntu or Windows. 

Again this is one example of running Linux along side Windows, I have this configuration on a 9570 and it was as easy as what I just described. I didn't change any secure boot settings or UEFI settings or anything other than setting the bootable Linux installer drive to first device. That build of Linux does everything else for you. Different Linux builds have different idiosyncrasies. 

 

7 Plutonium
35494

If your system came with Windows 10 installed, Secure Boot will already be enabled.  Some Linux distros now support Secure Boot, so if you'll be installing one that does, you should leave it enabled.  If not, then the only BIOS setting you have to change is Secure Boot, which has its own section in the BIOS and it's just that one option.  Just disable it.  Windows 10 will still keep running fine, although you won't have the anti-rootkit benefits of Secure Boot.


35615


@AArak wrote:

As an example, in the case of Ubuntu 18.xx in a dual boot configuration, download the Ubuntu image, flash it to a thumb drive (etcher makes this easy). Restart the laptop (leaving the newly flashed bootable drive in a usb port) and hit the F2 key as soon as the Dell logo appears. In the boot menu in the BIOS set the flash drive to be the first bootable device. Restart and the Ubuntu installer should load. In the case of that Linux build it pretty much does everything for you to make the system dual boot to include creating it's own ext4 partition. After installation the system will boot to a menu that lets you select Ubuntu or Windows.

 


When using UEFI booting, you don't set USB devices at the top of the boot order because USB devices set up for UEFI booting don't even appear in that list.  The boot list on UEFI systems only shows devices that are registered in the firmware.  But even if you were using Legacy BIOS booting, moving a USB device to the top of the boot list just to install an OS once is a waste of time.  The better way is to press F12 at boot to access the one-time boot menu.  For UEFI systems, that's where you'll see the USB device listed, and again even for Legacy BIOS systems, this is much faster overall.


35607

thank you both for your reply. Unfortunately in my case in addition to disabling the secure boot, I have to modify other things (enable "Legacy options Roms") otherwise the boot drive is not performed. Moreover, with any proven linux distribution (Kali, pureOS, ubuntu, mx) the pcie is not recognized and therefore I can not install the operating system.

35584

If you have to enable Legacy Option ROMs, then you either didn’t use a Linux distro that supports UEFI or you didn’t prep your USB flash drive properly for UEFI. For the latter, I use a tool called Rufus to prep USB flash drives since it makes it easy to specify whether you want Legacy or UEFI. You should really fix that rather than falling back to Legacy. I’m pretty sure that Ubuntu works even if you leave Secure Boot on, which again you should if you can since it does have some value.

Not being able to see the SSD is probably because the SATA Operation setting in the BIOS (which also affects NVMe SSDs, despite the name) is set to RAID and it needs to be on AHCI for Linux. Unfortunately, changing this setting will mean you’ll also need to reinstall Windows to get it set up properly for the new mode.


35575

exact. But if I imposed the SATA Operations in AHCI, I install linux, and then set the Sata Operation in Raid again, it works both windows and linux? or will there be problems?

35564

I managed to make windows 10 work by leaving the AHCI option without formatting. Now everything works, both windows and linux. I followed this guide https://medium.com/@peterpang_84917/personal-experience-of-installing-ubuntu-18-04-lts-on-xps-15-957... .

thank you all.

23259

You'd have to switch that setting every single time you wanted to boot one OS or the other, which I think would become inconvenient very quickly, so if you want to dual boot I would simply bite the bullet, change to AHCI, reinstall Windows from scratch, and then install Linux.  I recommend reinstalling Windows first because Linux provides options to simplify dual boot setups if it detects an existing Windows installation, but Windows doesn't try to help set up dual boot if it already sees a Linux installation.


35565


@Toto-xps15 wrote:

I managed to make windows 10 work by leaving the AHCI option without formatting. Now everything works, both windows and linux. I followed this guide https://medium.com/@peterpang_84917/personal-experience-of-installing-ubuntu-18-04-lts-on-xps-15-957... .

thank you all.


Nice.  I had heard that there was a way to do things in Safe Mode to make that work, but I never looked at the details in order to confirm.  In any case, I hope you managed to install Linux in UEFI mode.  If so, you should be able to disable Legacy Option ROMs again and possibly even enable Secure Boot again, depending on the version of Linux you installed.  If disabling Legacy Option ROMs breaks your Linux environment, then I would really recommend reinstalling Linux properly in UEFI mode so that you don't have to keep Legacy Option ROMs enabled.


Latest Solutions
Top Contributor