Linux Wireless Driver for Dell Vostro 1500

Recetly (in January) I've purchased Dell Vostro 1500. Because I need Linux for my work I decided to install SUSE 10-1 distro on it. After carefully partitioning HD and choosing details of installation (GRUB on MBR) I made it work.

I was quite dissapointed when I found that my wifi card does not work. The card is: Dell Wireless 1390 802.11g Wi-Fi mini card.

I started poking around, first what I did is to find out what my kernel release was (uname -a), and it is 2.6.16. I tried on google.com to find info how I can find the driver (my Windows XP still has connection to Linux by using WR/RD FAT32 logical partition by both systems, so I can do this from Windows XP, download to it all neccessary packages).

This is what I found on the net. Detail description what packages to use  and with what kernels:

First, what I did, I upgraded my kernel to (downloaded one from the net: http://downloads.openwrt.org/sources/). Recompiled, have some work to do on <make menuconfig> (to setup correct environment, not easy work to do), then I updated GRUB script with a bit more feeling blakks/details in between.

So after I reboot from newly installed linux- (I've read somewhere that kernels above 2.6.17 are able to support Dell's Wi-Fi, and NOT below).

I did two things. First I downloaded b43-fwcutter-011, and make it executable. Installed it in /src/local/sbin, so I have it included by system in $PATH.

Then I downloaded broadcom-wl- driver, compiled it, and with cutter tool installed it in /lib/firmware .

After rebooting I found that Wi-Fi card still does not work. Please, be aware that I included 802.11mac layer in menuconfig (it is on in .config) and all neccessary SW which is a MUST in order to make broadcom driver to work.

The thing I noticed is that it require for some reasons kernel 2.6.24 or later. I tried to compile kernel 2.6.24, but after make it recognize by GRUB, I was not able to boot from it. I guess I did NOT adjust all things I needed for it to boot sucessfully. I worked on this a bit, but so far I had no success. I'll rethink how to approach this problem.

In mean time, I tried to comply with kernel requirements, so I downloaded from: //downloads.openwrt.org/sources/ another broadcom driver, b43legacy. It is called and has only object code ready for fwcutter tool to be installed.

I executed b43-fwcutter -w "$FIRMWARE_INSTALL_DIR" wl_apsta-, it installed it in /lib/firmware making b43legacy directory.

After rebooting kernel my Wi-Fi does not work.

Any clue what possibly could go wrong in all of what I did? Any steps I've missed here, or maybe I did not include in .config some other drivers/SW necessary for this thing to work?

Best Regards,
0 Kudos
3 Replies

Re: Linux Wireless Driver for Dell Vostro 1500

0 Kudos

Re: Linux Wireless Driver for Dell Vostro 1500

I would try upgrading to SuSE 10.3 and set up the wifi with YaST. Compiling the kernel without adding the proper kernel sources for YaST may break some things. Alternatively 10.1 should have an upgrade tool in YaST. The days of compiling your own kernel for hardware support are behind us. If you need the latest and greatest just add a repository that has the bleeding edge kernel on it and run an update.

If you are using KDE you may even be able to set it up without YaST.

Hope this helps.
0 Kudos

Re: Linux Wireless Driver for Dell Vostro 1500


Initially I tried to switch to you solution with NDISwrapper, I carefully read pointer on the net:

The real problem was that I could NOT find trace of ANY wireless connection in step 6:

6. Configure network manager to use your wireless card
  1. Open the Networking Admin tool (System | Administration | Networking), select the Wireless connection and click Properties, ensure the Enable roaming mode checkbox is ticked.
  2. Click the Network Manager icon (computers icon in the top right corner of system tray), your network ESSID should be shown in the drop-down list. Select your network by clicking on it.
If the Network requires any further configuration (eg WEP key), a dialog should appear, select the correct settings and paste in your key.

This is why I downloaded (by ChainedGhost suggestion) distro SuSE 10.3. It is whopping 4.1GB as iso image. I burned one DVD in order to make it installable.

Installed SuSE 10.3. SuSE during installation immediately recognized the card, and placed/set all important services/drivers there. The driver comes up (b43), the 80211mac is in there, but it is NOT willing to start at all.

Initial kernel distro uses is (for the record).

It does not see wireless LAN network. I think I set the things properly (WPA to PSK, operating mode to managed/infrastructure), but I could not find network manager which manages SSIDs. Seems that card is dead, regardless recognition by HW manager.

I'll try more things. If anybody uses SuSe 10.3 with Vostro 1500, and the wireless card Dell Wireless 1390 802.11g Wi-Fi mini card, please, post/add whatever you think it is important for the solution.

0 Kudos