Highlighted
1 Copper

PowerEdge T620 IDRAC

Bonjour, IDRAC ne répond plus sur mon serveur, j'ai une erreur au post message : "idrac not responding rebooting"

je n'ai accès a rien concernant idrac.

le LCD du panneau avant est éteint, le bouton "i" du panneau avant est allumé en bleu fix.

l'interface RJ45 ne répond pas.

je ne sais pas pourquoi cela fait ca et je ne sait pas quoi faire.

j'ai essayé de presser 15 seconde  le bouton "i" mais depuis que je l'ai fait la 1er fois le lcd est éteint.

si vous avez des idées (sauf changer la carte mère)  ?

 

merci

0 Compliments
2 RÉPONSES 2
Highlighted
Modérateur
Modérateur

Re: PowerEdge T620 IDRAC

Bonjour,

 

Vous pouvez essayer de faire un drain électrique du serveur.

Si le problème persiste, il faudra envisager le remplacement de la carte mère.

 

Cordialement,

Stéphane Thiallier
Social Media and Communities professional

Customer feedback | What am I doing? Please contact my manager
0 Compliments
Highlighted
1 Copper

Re: PowerEdge T620 IDRAC

oui, j'ai fait un drain électrique de la carte, ça n'a rien changé.

En ce moment, je m'oriente plus vers un débogage de la carte, comprenez que je ne suis pas prés a remplacer une carte seulement car une NAND est corrompue... Ca revient a changer son ordi car un soft a planté...

j'ai soudé une connecteur sur le port BMC_UART de la carte mère afin de lire les information qu'elle me transmet, ce qui m'a permis de voir que le module IDRAC boot en boucle (donc reste bloqué dans la phase de boot, ce qui explique pourquoi il ne répond pas). il semble qu'il ne parvient pas a lire une partie de la NAND de 2GO qui contient IDRAC. 

deux solution apparaissent alors :

  1. la mémoire NAND U_EMMC est corrompue et elle ne contient plus les information nécessaire a idrac pour booter. solution : re-flasher la NAND pour y remettre une version de IDRAC viable.
  2. la memoire NAND U_EMMC est complétement morte et le répond pas au bootloader. solution : remplacer la NAND par une neuve et voir comment je peut la refalsher.

voici un dump de ce que je lit sur le port UART de la carte mère:

U-Boot 2009.08 (May 11 2019 - 03:59:51) Avocent (0.0.3) EVB

CPU: SH-4A
BOARD: R0P7757LC00xxRL (Cn step) board
BOOT: Secure, HRK generated
DRAM: 240MB
(240MB of 256MB total DRAM is available on U-Boot)
ENV: Using primary env area.
Undefined env fwu_act
Undefined env Failsafe_PowerON_Lockout
Undefined env wdt2cnt
Undefined env cpld_recover_cnt
Undefined env ddr_recover_cnt
Restore env FWN=0x2f057c_0x5e098687,0x624d000_0x43309725,0x6dfc4_0x28291aef,0x13 2000_0x34bbc90a
Restore env FWN1=0x2f0579_0x3fc30fe9,0x653d000_0x90b77173,0x6db9c_0x966e5ecb,0x1 32000_0x83c2e56c
Restore env etherc0=90:B1:1C:33:6B:FA
Restore env getherc0=90:B1:1C:33:6B:FB
Restore env first_ac=yes
Restore env ethaddr=90:B1:1C:33:6B:FA
Restore env eth2addr=90:B1:1C:33:6B:FB
Restore env macs_in_res1=yes
Restore env ethact=sh_g_eth.0
Restore env dmn=disabled
Restore env wdt0cnt=1
In: serial
Out: serial
Err: serial
PCIe: Bridge loaded with 0x18000 bytes
WDT2: Booted Lower Vector, 'uboot1'
sh_mmcif: 0, sh-sdhi: 1
Net: sh_eth.0, sh_g_eth.0
INFO: 00:002 Start-up -to- util_idrac_main()
INFO: 00:004 U-Boot 2009.08 (May 11 2019 - 03:59:51) Avocent (0.0.3) EVB
INFO: 00:007 U-Boot checkin date(10-04-2018) Version(1.1.34)
INFO: 00:006 iDRAC PPID <NULL>
INFO: 00:003 SPI NOR init 4096 KiB MX25L3206E bus=0 cs=0, speed=1000000, mode=3
INFO: 00:007 SH-4A Product: Major Ver=0x31 Minor Ver=0x13 C3 Little endian
Family=0x10 Major Ver=0x30 Minor Ver=0x0b
INFO: 00:140 BCM54610 OUI=0x00d897 Model=0x26 Revision=0x0a PhyAddr=1
INFO: 00:006 Dedicated monolithic mgmt NIC disabled
INFO: 00:068 SD CARD: Device: sh-sdhi Manufacturer ID: 2 OEM: 544d
Name: SA04G Tran Speed: 25000000 Rd Blk Len: 512
SD ver 2.0 HC: Yes cap(<2gb): 3904897024 cap(>2gb): 0
ext_rev: 0 rst_n: 0 ext[96]: 0
mmc read failed, err=-84
** Can't read Driver Desriptor Block **

 

 

 

PS : au passage, j'ai mis une carte SD avec l'image firmimg.d7 "IDRAC + Lifecyrcle", mais je ne parviens pas a l'utiliser. ma carte sd fait 4go y a il une limitation de taille pour que cela fonctionne ?

comment puis je accéder a un terminal qui me permettrais d’interagir avec idrac ou tout du moins u_boot afin de vérifier l’intégrité de la NAND ?

actuellement je ne parviens pas, via la liaison UART,  a envoyer des commandes a idrac, le serveur n'écoute pas et ne répond pas.

j'ai crus comprendre qui est possible de faire des contacte sur la carte mère afin de rebooter IDRAC puis d'interompre le boot afin que le serveur ce mette a écouter. il s’agirait de l’emplacement dip switch (non peuplé) "sw7" de la carte mère.

pouvez vous me communiquer des information relative au débogage de cette carte mère ?

cordialement.

 

 

 

0 Compliments