Highlighted
2 Bronze

Retour d’expérience PowerEdge 2950 – Xéon X5470

Bonjour à vous,

Ci-dessous mon expérience avec mon jouet Dell que j'ai depuis 8 ans maintenant. J'ai donc décidé d'Update les mon 2950. 

Pour faire une présentation rapide : Je gère un petit parc informatique approximativement : 150 PC - 70 Tablettes – 5 Serveurs dont Lenovo System x3650 M5 & Windows – Android - Linux avec des outils du type : Proxmox – Virtual Box – Hyper-V - Alcasar – Nextcloud - Glpi & Ocs – Centreon – Nginx – Wordpress - …  je travaille avec un MacBook Pro dans le secteur médico-social – hôtelier - Camping.

En préambule, je dirais que j’ai trouvé très compliqué de faire les mises à jour (Firmware) de mon serveur, je trouve que Dell nous demande de travailler sur une liste d’Os couteux (Red Hat Pro – Windows Serveur – Vmware - …) mais il est vrai que je parle pour mon vieux tagazou. Pour l’os j’utilise Proxmox même si j’ai une licence Windows Serveur 2012 RT2 à titre personnel.

Mes prévisions d'achat : Cpu & dissipateur – 32 Giga de Ram à la place de 4 – Ventilateur (1 HS) – Batterie pour le Perc – DRAC – Disque 2 Terra (1 Hs)

Tout commence avec la Ram, je crois avoir lu qu’il existait 2 modèles mais sans plus.

Puis vient les Cpu : Je souhaite mettre les meilleurs processeurs de l’époque. Sur ce serveur j’utilise : OpenVpn avec Firewall Iptables - Plex – OpenMediavault – Nextcloud – postgresql (Pour des tests lors de developpement perso).

1ère difficulté déterminé le modèle de mon PowerEdge.

Je n’ai pas vraiment trouvé de technique pour lire III. Avec le comparatif des documentations, je lis 64 Gigas sur le modèle 3 et 32 sur le 1. Grâce à Dell OpenManager (sur Proxmox) je vois que je peux installer 64 gigas de Ram donc j’ai le modèle 3 Super. Plus tard, je crois avoir lu dans le serveur sur une étiquette modèle III (mais plus tard)

https://www.dell.com/downloads/global/products/pedge/en/pe_2950_iii_spec_sheet.pdf

Je lis « Up to two quad-core or dual-core Intel® Xeon® 5400, 5300, 5200, » Je vois en parallèle une vidéo où il est lancé un Xeon X5470.  https://www.youtube.com/watch?v=vYbgqeyyPGM

Après de longues recherches et notamment de comparatif de processeur (https://ark.intel.com ). Je fais le choix d’acheter 2 Xéon X5470, je pense que c’est le meilleur processeur pour mon PowerEdge 2950 version 3 du coup ^^

Après l’installation des processeurs le message suivant apparait : « unsupported cpu combination »

Je décide d’update tous les Firmware et pour cela j’attends de recevoir le DRAC5.

A partir de là, tout est devenu extrêmement compliqué :

Je n’arrive pas à avoir la console à partir du DRAC ni sous Mac ni sous Windows ni sous Linux & ni en natif (Linux) ni en java en donnant tous les droits à Java sur l’Ip. (Peut-être que mes versions d’Os sont trop récentes et il n’y avait pas encore la mise à jour du Firmware du DRAC, je dois tester à nouveau).

Quand je rentre le numéro de série sur le site de Dell, le bios proposé est la version 2.3.1 alors que sur une vidéo de démarrage d’un Poweredege 2950 avec 2 X5470 je vois une version 2.6.1. Je dois donc faire une recherche manuelle PowerEdge 2950 Bios 2.6.1 puis lorsque je rentre le numéro de série sur la page de Dell il me propose finalement la 2.7.0. (Plus tard, j’ai découvert que cette version était dans le Dvd SUU)

Cela n’a pas résolut mon problème.

Je décide d’aller plus loin encore. Je télécharge comme il est proposé sur le site « Dell Support Live Image Version 3.0 » & « Q1 Server Update Utility DVD ISO v7.2.1 ». Il fallait trouver la commande à lancer « sudo ./suu -g ». C’est vrai que c’est simple quand on le sait.

En fait l’image 3.0 ne supporte pas la commande « sudo ./suu -g » du Dvd. Il faut mettre la version 2.0. Et lors de l’utilisation de la 2.0, hormis la perte du réseau au bout de 1 à 2 minutes je peux enfin taper cette commande. Mais le « Q1 Server Update Utility DVD ISO v7.2.1 » n’arrive pas à faire l’inventaire du serveur (Problème dans /var/log/dell/suu) alors que la version « Dell DVD ISO - Dell Server Updates, v.5.5.0, A00 » oui (je pense car au bout de 15 minutes je n’ai pas souhaité attendre plus) pas de message d’erreur…

Ce n’est pas grave, je décide de faire manuellement les mises à jour avec l’aide du référentiel du 2950 du Dvd SUU. Une fois que l’on comprend qu’il suffit de faire « sudo ./nom_Firmware.BIN », c’est facile. J’ai donc Upgrade BMC-DRAC-PERC-NETWORK et je dois certainement en oublier. (J’avais déjà fait l’update du Bios de 2.3.1 en 2.7.0 en commande DOS)

Finalement, je ne peux toujours pas mettre les 2 Xéon X5470, si vous avez une solution je suis preneur bien qu’avec résilience et tristesse je me dise qu’en fait il n’y en a pas. Je bloque sur :

  • Comment a-t-il fait sur sa vidéo !
  • Pourquoi les processeurs sont reconnus au démarrage 
  • sur le fait que j’ai vu en vente des PowerEdge avec ces processeurs.

Je ne sais plus trop quoi faire. Dois-je downgrader en 2.6.1 ?

Merci de toutes l’aide que vous pouvez m’apporter.

Vince

Étiquettes (5)
Dell PowerEdge 2950 III 2x QUAD-Core XEON X5470 3.33GHz 64GB RAM 2u Server Dell PowerEdge 2950 2U Intel Xeon Processor 2 x Intel Xeon CPU X5470 3.33GHz 3325 ...
0 Compliments
9 RÉPONSES 9
Highlighted
Modérateur
Modérateur

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

Bonjour,

 

le processeur X5470 est bien référencé dans ma base comme état compatible avec les serveurs PE2950 MLK III sous la référence de kit C334J ou de CPU N112G dont les caractéristiques techniques sont 3.3/1.3GHz Harpertown Xeon Processor.
Vous avez bien fait de mettre à jour le bios en dernière version, la version 2.7.0 du bios est bien la version requise pour faire fonctionner ce type de processeur. Avez vous également mis à jour le  firmware DRAC du serveur ou à défaut de DRAC celui de la BMC?

Ensuite, je vous propose de faire un drain électrique du serveur puis de tester les processeurs un par un avec une seule barrette mémoire installée en A1.

 

Cordialement,

Stéphane Thiallier
Social Media and Communities professional

Customer feedback | What am I doing? Please contact my manager
0 Compliments
Highlighted
2 Bronze

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

Bonjour Stéphane,


Merci pour votre réponse mais hélas cela n'a pas fonctionné.
La bonne nouvelle c’est que le processeur est bien compatible !

  1. Réalisation du drain électrique du serveur (20s sur le bouton d’allumage sans alimentation électrique)
  2. Tester les processeurs un par un avec une seule barrette mémoire installée en A1
    Changement de Ram avec celle d’origine en A1
  3. Vérification des Firmware
    1. 2950_ESM_Firmware_4NNNG_LN32_2.50_A00.BIN : BMC V2.5 Ok
    2. ESM_Firmware_9WH0P_LN32_1.05_A01.BIN : V1.05 OK
    3. PE2950_BIOS_LX_2.7.0.BIN : V2.7.0 Ok
    4. Systems-Management_Firmware_D8GP9_LN32_1.65_A00.BIN : Drac 5 V1.65 Ok
    5. Les autres Firmware n’ont pas pu être installés et la command ./suu -u n’a pas fonctionné également

Je pourrais me demander si les processeurs n’ont pas de souci mais ils sont parfaitement identifiés à l’allumage et les 2 cela serait étonnant.

En parallèle, je n’arrive pas à lancer la console à partir du DRAC 5, mais je n’ai pas passé que 10 minutes. En tout état de cause cela ne change pas ma problématique des processeurs.

Auriez-vous une autre idée ? Un Firmware que je n'aurais pas update ?
Merci,

0 Compliments
Highlighted
Modérateur
Modérateur

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

Bonjour,

Quel a été le résultat du test individuel des processeurs?

Arrivez vous a renter dans le bios du serveur?

Si la séquence de POST s'arrête, pouvez vous me dire à quel étape ? (message d'erreur, capture d'écran)

Avez-vous essayé avec une autre barette de RAM

Avez vous bien retiré toutes les cartes PCI présentes dans le serveur pour ce test?

 

Cordialement,

Stéphane Thiallier
Social Media and Communities professional

Customer feedback | What am I doing? Please contact my manager
0 Compliments
Highlighted
2 Bronze

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

Bonjour Stéphane,

  • Quel a été le résultat du test individuel des processeurs?
    • Même résultat : "Unsupported CPU combination" "System halted !"
  • Arrivez vous a renter dans le bios du serveur?
    • Non : Ce message arrive après les tests du disque dur juste avant le boot sur la partition système.
  • Si la séquence de POST s'arrête, pouvez vous me dire à quel étape ? (message d'erreur, capture d'écran)
    • Ce message arrive après l'ensemble des tests (RAM - DRAC - RAID) juste avant le boot sur la partition système ou d'aller dans le Bios.
  • Avez-vous essayé avec une autre barette de RAM
    • Oui . Une seule en A1
  • Avez vous bien retiré toutes les cartes PCI présentes dans le serveur pour ce test?
    • Je n'ai pas d'autre carte PCI hormis peut-être le DRAC 5

Merci pour votre aide !

IMG_7728.jpeg

Avec l'ancien processeur lecture des logs :

IMG_7735.jpeg

0 Compliments
Highlighted
Modérateur
Modérateur

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

Bonjour,

 

Pourriez vous effectuer un clear NVRAM avec le jumper de la carte mère avant l'ajout d'un nouveau processeur en emplacement CPU1? Je n'aurais pas d'autre manipulation à vous proposer.

 

Cordialement,

Stéphane Thiallier
Social Media and Communities professional

Customer feedback | What am I doing? Please contact my manager
0 Compliments
Highlighted
2 Bronze

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

Bonjour,

Déjà fait hier et ce n'a pas fonctionné 😕

C'est dingue cette histoire quand même.

0 Compliments
Highlighted
Modérateur
Modérateur

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

Navré de la situation,

 

Ce serveur étant ancien je n'ai pas d'autre ressources/test à vous proposer.

Nous allons bien entendu laisser ce sujet ouvert au cas ou l'un des membres de la communauté voudrait participer à la discussion.

 

Cordialement,

Stéphane Thiallier
Social Media and Communities professional

Customer feedback | What am I doing? Please contact my manager
0 Compliments
Highlighted

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

salut

 

tu dis que chaque proc boot ... ok...

donc chaqu un est reconnu individuellement...

deja bien 🙂

je me demande si tu n as pas en fait 2 procs légèrement differents , qui empechent par exemple le qpi de bien fonctionner.

tes 2  cpus ont ils bien ete fabriqués au meme endroit ?

une fois j ai eu un soucis identique , j avais un cpu "malay" , l autre costa rica ...

parfois quand tu n as pas acheté deux ou 4 xeons pairés y a des surprises 😲...

 

un autre truc , : permute tes cpus ....

guillaume 

 

0 Compliments
Highlighted
2 Bronze

Re: Retour d’expérience PowerEdge 2950 – Xéon X5470

Salut Guillaume, Merci pour ton aide. Ils sont tous 2 bien reconnu aussi bien seul que les 2 ensembles mais toujours ce message . "Unsupported CPU combination." "System Halted !" Du coup, je vais renvoyer les processeurs et en reprendre 2 à nouveau et je m'acharne sur ce modèle X5470. Car je pense que c'est le plus puissant possible pour le PE 2950. Je me dis que ça vient des processeurs ! Je ne vois que ça. Tu as totalement raison c'est pour ça que j'ai pris : "Matching Pair". Je ne manquerai pas de vous tenir informer. Merci,
0 Compliments