Highlighted
joyner5912
Copper

In-band SCOM discovery fails for PowerEdge R720, possible invalid WMI HardwareManufacturerName returned

We have two Dell R720 PowerEdge servers (BIOS 2.1.3, 11/20/2013) (Dell Server Administrator 7.3.0) running Windows Server 2012 R2 to be discovered by SCOM 2012 R2 with Dell Server Management Pack Suite 5.1. Management packs are imported and Feature Management State for Server (in-band) Monitoring shows Monitoring Level "Detailed Feature" In Use Version "5.1.0". Creating a Log Level override for Dell Server Discovery results in the following Discovery_DellServer output: 5/2/2014 11:28:00 PM ---- ------------------------------------------------------ 5/2/2014 11:28:00 PM ---- INFO: Script - Dell Server Discovery : Start() 5/2/2014 11:28:00 PM ---- INFO: Script - Arguments: Computer, minOMSAVersion = HOSTNAME.domain, 6.2 5/2/2014 11:28:00 PM ---- Retrying for 0 time... 5/2/2014 11:28:00 PM ---- INFO: Win32_ComputerSystem attributes retrieved successfully 5/2/2014 11:28:00 PM ---- INFO: HardwareManufacturerName Name retrieved successfully 5/2/2014 11:28:00 PM ---- Hardware Manufacturer Name query : DELLOE 5/2/2014 11:28:00 PM ---- INFO : Script - Dell Server Discovery : End() 5/2/2014 11:28:00 PM ---- ------------------------------------------------------ Examination of the embedded discovery script seems to show that the text field "Dell" is expected for the WMI query on HardwareManufacturerName, and when "DELLOE" is received, the discovery script exits without creating any objects. Hopefully this detailed description of the issue will help a Dell SCOM management pack expert solve our issue. Thanks! John Joyner
0 Kudos
1 Reply

RE: In-band SCOM discovery fails for PowerEdge R720, possible invalid WMI HardwareManufacturerName returned

Hello John Joyner - Dell Server Management pack is not currently designed to discover/monitor OEM servers (i.e., servers that are not branded as Dell PowerEdge servers).

0 Kudos