Highlighted

Server MP: Interface Status changes

Hi there!

I'm experiencing the following situation on System running Windows Server 2012 and monitored by SCOM 2012:

Some of the NICs are changing their status frequently, others are unhealthy all the time and others are healthy all the time.

What I found either are plenty of 21402 events in the SCOM event log with the following details:

Forced to terminate the following process started at 14:44:38 because it ran past the configured timeout 300 seconds.

Command executed: "C:\Windows\system32\cscript.exe" /nologo "DellServerNICUnitoper1.vbs" {myid} {myid} $Config/Computer$ OPS LAN3

Workflow name: Dell.WindowsServer.EnrichedNIUnit.OperStatus.PollUnitMonitor

Instance name: OPS LAN3

Instance ID: {myid}

As you can see, the parameter "$Config/Computer$" has not been replaced by a value. Maybe that is a problem. Further you can see, that the NICs name (in that case and in the others as well) has a space character "OPS LAN3".

I do have the following NICs:

OPS LAN 1-8 (NIC Team members)

OPS LAN Team

SAN NIC1

SAN NIC2

VM SAN1

VM SAN2

vEthernet (CSV)

vEthernet (LM)

vEthernet (MGMT)

 

Im getting that for all NICs that are member of a teaming and from SAN NIC1. And as it seems only on WS2012.

From my PoV it seems that I have to issues: one is the discovery above (currently OPS LAN8 disappeared from SCOM) and the frequent status changes.

Any idea regarding that?

Thanks in advance,

Patrick

0 Kudos
11 Replies

Re: Server MP: Interface Status changes

Zero replies? Really?

0 Kudos

Re: Server MP: Interface Status changes

Hi Patrick Apologies for the silence...We had been looking to answer this after investigation on a repro - we are not there yet Smiley Sad ... we will be validating the MP against Windows 2012/SCOM 2012 SP1 combo in the next release of the MP. As you have pointed out in your analysis, the parameter "$Config/Computer$" has not been replaced by a value. Could you please clarify: are you seeing the problem only when the name has spaces? 2) You mentioned that it seems to be Windows 2012 specific; does it work for other versions? 3) What version of SCOM are you using? 2012 SP1? Regards Thomas
0 Kudos

Re: Server MP: Interface Status changes

Hi Thomas!

Here is my feedback so far:

1) will check ASAP.

2) no, not yet. We currently have 2x Server 2012 running Hyper-V and the error is occuring only there.

3) yes, 2012 SP1

Next version means what in terms of timeframe?

Thanks,

Patrick

0 Kudos

Re: Server MP: Interface Status changes

Regarding 1):

As it seems (!), the monitor is working (but maybe not as expected). I come to this conclusion because I see, that the monitor "Physical Network Interface (Enriched) Operational Status Periodic Monitor" for "SAN NIC2" on Server31 changes it's health state from time to time.

The last 13 changes where:

Time Operational State

3/26/2013 8:51 PM Success

3/23/2013 11:46 AM Success

3/22/2013 8:47 PM Warning

3/22/2013 8:40 PM Success

3/21/2013 6:13 PM Warning

3/21/2013 9:42 AM Success

3/21/2013 9:13 AM Warning

3/20/2013 5:42 PM Success

3/20/2013 3:13 PM Warning

3/20/2013 10:42 AM Success

3/20/2013 6:11 AM Warning

3/19/2013 3:42 PM Success

3/19/2013 3:12 PM Warning

Further, all other NICs are shown in the HE.

On the other hand: on Server32 I can't see any NIC (but will investigate in that behavior by my own).

Cheers,

Patrick

0 Kudos

Re: Server MP: Interface Status changes

OK... no change after renaming the NICs to names without blanks.

And: Server32 shows the NIC again (after agent restart?).

0 Kudos

RE: Server MP: Interface Status changes

Still we do have this issue, in the meantime MP version 5.1

I can't believe that this is a unknown issue? Really?

Thanks,

Patrick

0 Kudos

RE: Server MP: Interface Status changes

I am also getting this issue, also Hyper-V 2012 with SCOM 2012 SP1. Been happening for a while but only just getting round to investigating it. Error I am seeing below. Loads of free memory and CPUs are barely pushed. No AV installed on the Hyper-V cluster nodes. Getting this across all nodes. Other MPs seem to be working fine. Is there any sign of an updated MP that may resolve this?

 

Last modified time: 3/11/2014 9:10:11 AM Alert description: Forced to terminate the following process started at 09:04:11 because it ran past the configured timeout 300 seconds.

 Command executed:     "C:\Windows\system32\cscript.exe" /nologo "DellServerNICUnitoper1.vbs" {8479EA0C-256D-5ABF-E4C0-88F6DC038E50} {74EB1B27-2106-0CF1-158B-036C484BF6B2} $Config/Computer$ NIC-CLUS-01

Working Directory:          C:\Program Files\System Center Operations Manager\Agent\Health Service State\Monitoring Host Temporary Files 2144\5254\

 One or more workflows were affected by this.

  Workflow name: Dell.WindowsServer.EnrichedNIUnit.OperStatus.PollUnitMonitor

 Instance name: NIC-CLUS-01

 Instance ID: {74EB1B27-2106-0CF1-158B-036C484BF6B2}

0 Kudos
bradje1
Gold

RE: Server MP: Interface Status changes

I've been having this issue for a long time and even on Version 6 of the Dell SCOM MP.

Is there a fix/workaround for this?

Thx,

John Bradshaw

0 Kudos
bradje1
Gold

RE: Server MP: Interface Status changes

Anyone from Dell?

Thx

0 Kudos