Highlighted
bluelemon
1 Nickel

Power Plug Status Abfragen problem auf Dell venue 11

hi, Ich habe für Installationen die Stromversorgeung an Dell venues die ca 1,5 ahre alt sind mit Battery.PowerOnline (batch Script) abgefragt. Wenn eine definierte Zeit False kommt wird das Gerät ausgeschaltet. Funktionierte wunderbar um die Geräte mit Power Schaltung zu steuern. Bei älteren Dell Venues 11 mit Windows 8.1 bekomme ich immer mit Battery.PowerOnline ein False, egal ob Strom dran oder nicht. Gibts da einen Trick das es klappt, BIOS? wo kann man da dran drehen. grüße
3 ANTWORTEN 3
Community Manager
Community Manager

Betreff: Power Plug Status Abfragen problem auf Dell venue 1

Hi,

Du redest von diesem Skript hier?

https://www.sysnative.com/forums/windows-8-windows-rt-tutorials/3734-wmi-battery-status-batch-file.h...

Ich kann dir deine Frage nicht beantworten. Aber vielleicht liegt es an der Akkukapazität. Diese fließt ja in die Rechnung des Batch Files mit ein. Und da der Fehler nur bei älteren Systemen auftritt, wäre das Denkbar. Sofern das BIOS aktuell ist, wüsste ich nicht, wo man da "drehen" kann.

Grüße

Tom



DellTom Guenther
Community Technologist - Business Client
Social Media and Communities Professional
Twitter | LinkedIn | XING
bluelemon
1 Nickel

Betreff: Power Plug Status Abfragen problem auf Dell venue 1

ja im prinzip, bischen vereinfacht, aber %Battery% gibt imer PowerInline=FALSE zurück. Ist der Fehler eher auf Geräteebene zu suchen oder könnte ein W10 Update was bringen? @echo off for /F "tokens=* delims=" %%A IN ('WMIC /NameSpace:"\\root\WMI" Path BatteryStatus Get PowerOnline /Format:list ^| FIND "PowerOnline"') DO SET "Battery=%%A" if /I "%Battery%"=="PowerOnline=TRUE" ( set doShutDown=0 ) else ( set doShutDown=1 )
Community Manager
Community Manager

Betreff: Power Plug Status Abfragen problem auf Dell venue 1

Hi,

Der Befehl vereinfacht:

WMIC /NameSpace:"\\root\WMI" Path BatteryStatus

gibt dir also ebenfalls False bei PowerOnline zurück?

Wie ist der Ladezustand normal im OS? Wird da angezeigt, dass das Netzteil erkannt wurde und das der Akku lädt?

Grüße

Tom



DellTom Guenther
Community Technologist - Business Client
Social Media and Communities Professional
Twitter | LinkedIn | XING