Highlighted
Sirius.lee
1 Copper

Dell E173FP external monitor disconnects shortly after connecting.

I have a new dell XPS 15 (L502X) running both Windows 7 and Ubuntu 11.04 with both the intel HD 3000 and nVidia 540M graphics cards. I recently bought a mini displayport to vga adapter to hopefully be able to hook up my old external monitor in extended mode. After plugging in the VGA cable from the monitor to the adapter, I plug the adapter into the mini displayport and windows 7 instantly recognizes the monitor, and I can easily set it up to display as I want it to. However, after about 30 seconds or so, the monitor suddenly "disconnects" and is no longer detected by my laptop. The monitor itself claims to be in power save mode. I get this exact same problem when running Ubuntu. I know that the monitor is in decent condition, as it works perfectly on my old laptop running windows XP. Does anyone have any ideas on this issue? I've spent more than two days now searching for a solution but to no avail. Thanks, any help would be much appreciated.

0 Kudos
1 Reply
mediterran81
1 Copper

Re: Dell E173FP external monitor disconnects shortly after connecting.

Assumptions can't be formulated in that case!

You need to find another VGA external monitor and test with it. Some old external monitors have old EDID format information and likely the driver installed on your Windows XP took that in consideration.

What video output port do you have in your old XP computer?

Some cable adapters (Mini DP to VGA) might cause this problem too.

Anyway, the problem you have seems to be related to POWER (electricity)! After a short time, the miniDP stops supply power to your monitor input port thne it goes to sleep!

The problem could also be solved using a powered adapter the one with a second usb calbe to hook power)

0 Kudos