bradleyhanc
1 Nickel

Dell S2417DG 165Hz overclock isn't working

Jump to solution

Hi Guys,

So I just got this monitor and it's amazing. I've set it to 144Hz in Windows and that's all perfect.

When I try to overclock it, it's a completely different story, this is what happened:

  1. In Windows set refresh rate to 144Hz
  2. On the OSD I set response to "fast"
  3. On the OSD I set the overclock to 165Hz
  4. The monitor prompts me that it needs a restart and I accept
  5. The monitor initiates restart and then just stays black and nothing I do makes it come right

I've also tried turning power saving mode off before I do this and it still just goes black and doesn't come on.

Is there something I'm doing wrong? Are all these monitors capable of doing 165Hz or is it just silicon lottery?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
bradleyhanc
1 Nickel

RE: Dell S2417DG 165Hz overclock isn't working

Jump to solution

So apparently, it works now.

Anyone struggling with a black screen after overclocking, I hope this helps:

  1. On the OSD, enable overclocking
  2. Set the overclock refresh to 165 and choose yes to restart
  3. You should now get a black screen when the screen initiates, with "Power saving mode on" or something
  4. Unplug the Display Port cable from the monitor (not the computer, this is what I did)
  5. Choose the "Up" key on the monitor, this will prompt you again with some message
  6. Choose "Yes"
  7. Plug the Display Port Cable back in the monitor
  8. The screen should come back on now
  9. Choose the overclocked refresh rate in Windows (should be in the list of refresh rates now)

Hopefully that helps someone, I was trying literally EVERYTHING and it wasn't working.

Perhaps it's random or perhaps these steps will help.

Good luck!

1 Reply
Highlighted
bradleyhanc
1 Nickel

RE: Dell S2417DG 165Hz overclock isn't working

Jump to solution

So apparently, it works now.

Anyone struggling with a black screen after overclocking, I hope this helps:

  1. On the OSD, enable overclocking
  2. Set the overclock refresh to 165 and choose yes to restart
  3. You should now get a black screen when the screen initiates, with "Power saving mode on" or something
  4. Unplug the Display Port cable from the monitor (not the computer, this is what I did)
  5. Choose the "Up" key on the monitor, this will prompt you again with some message
  6. Choose "Yes"
  7. Plug the Display Port Cable back in the monitor
  8. The screen should come back on now
  9. Choose the overclocked refresh rate in Windows (should be in the list of refresh rates now)

Hopefully that helps someone, I was trying literally EVERYTHING and it wasn't working.

Perhaps it's random or perhaps these steps will help.

Good luck!