Sadifn
1 Copper

Dell ST2420L not displaying when using dvi and hdmi cables

I have a ST2420L and gtx280 video card, I cannot get the monitor to display using the dvi or hdmi cable, but I used a vga-dvi cable and it worked...any idea?  Thanks!

0 Kudos
9 Replies
Sadifn
1 Copper

Re: Dell ST2420L not displaying when using dvi and hdmi cables

also is this driver any use?

DELL_ST2420L-MONITOR_A00-00_R299077.EXE

dated 6/13/2011 version A00-00

0 Kudos
Sadifn
1 Copper

Re: Dell ST2420L not displaying when using dvi and hdmi cables

somehow, my computer doesn't seem to detect the dell monitor, in device manager under Monitors, it doesn't say dell ST2420l, just generic..something

0 Kudos
Moderator
Moderator

Re: Dell ST2420L not displaying when using dvi and hdmi cables

* Switch the computer and monitor off
* Unplug the power cord from the back of the computer
* Disconnect the monitor from the video card
* Remove the case cover
* Disconnect and reconnect all plugs, cables, and memory sticks (the memory sticks should click when fully inserted)
* Remove and reseat the video card in the motherboard slot
* Close the case cover
* Reconnect the monitor to the video card using only the DVI cable
* Reconnect the computer power cord
* Power on the monitor and then the computer
* Press the monitor Input Select button and choose DVI

0 Kudos
Sadifn
1 Copper

Re: Dell ST2420L not displaying when using dvi and hdmi cables

I tried that before, same problem.  How do you install the dell monitor drivers?  I unzipped the files and a windows pops up.  There were no further installation prompts.  Is this correct?

6.Click the Start button and then click Run.
7.Type C:\DELL\DRIVERS\R299077 in the Open textbox and then click OK.
8.Follow the on-screen installation instructions.

I have Windows 7 Ultimate 64 bits.  When I typed that command in, it just shows the same windows as when I first unzipped it.  I think the problem is that the drivers are not being installed.



0 Kudos
Moderator
Moderator

Re: Dell ST2420L not displaying when using dvi and hdmi cables

* Open the Device Manager
* Click the icon left of Monitors
* Double click the monitor listed
* Click the Driver tab
* Click the Update Driver button
* Click No, not at this time
* Click Next
* Dot Install from a list or specific location
* Click Next
* Click Don't search. I will choose the driver to install
* Click Next
* Click Have Disk
* Click Browse and navigate to C:\Dell\Drivers\R299077 or wherever you unzipped them
* Click the monitor inf file
* Click Open
* Click OK
* Click Next
* Click Finish
* Now the Device Manager- Monitors should show ST2420L

0 Kudos
Sadifn
1 Copper

Re: Dell ST2420L not displaying when using dvi and hdmi cables

Hi many thanks for your help!  I've seem to have found the problem, the dvi cable has broken pins, I got a new cable and now it properly detects the monitor.  The hdmi works, but on start up, sometimes it won't detect the monitor and sometimes it gives me a screen of scrambled colours and the computer will freeze.

0 Kudos
fasilak
1 Copper

Re: Dell ST2420L not displaying when using dvi and hdmi cables

Hi,

I am using a win 7 64 bit machine.

I have the same problem its not working with HDMI. When connected with HDMI it shows up the boot screen and windows logo animation. Before the Windows login screen appears the screen goes black with a animating dialog stating NO HDMI connected.

Please help me resolve this issue.

Thanks and regards,

Fasil.ak

0 Kudos
Ali Ongan
1 Copper

Re: Dell ST2420L not displaying when using dvi and hdmi cables

also is this driver any use?

DELL_ST2420L-MONITOR_A00-00_R299077.EXE

dated 6/13/2011 version A00-00

0 Kudos
BlueArchangel
1 Copper

RE: Dell ST2420L not displaying when using dvi and hdmi cables

Hi, I'm new around here. I bought a new monitor, is a Dell ST2420L, i was trying to make good use of the HDMI port but is not displaying signal at all, only analog signal, I installed and update the monitor, actually i run the update through the device manager and point manually to the file you upload and it still say that the device is up to date.

Before installing it displayed that a reconfiguration had to be done, it requires 1900x1280@60Hz (which by default my Video card established), after the installation and update it goes to energy saving mode and that's it, no more signal no matter how much you move the mouse or turn on and off the monitor. So far the VGA is doing the job but i would like to make use of the HDMI.

Please help me, maybe there is something else i should do, thanks in advance for your help.

0 Kudos