Monitors

Last reply by 05-20-2021 Solved
Start a Discussion
2 Bronze
2 Bronze
44782

Locking desktop icons in place?

Howdy. I recently purchased a Dell 22" monitor (fantastic btw) & have been running it in dual/extended desktop mode with my laptop. Everything works great except when I close my laptop lid or open it when starting a new session. Every time my icons are scattered all over the desktop. As I am a recording musician this is particularly frustrating as I have a ton of shortcuts that need to be exactly where I place them. I've tried locking icons in place. Nadda.Using xp.

Any thoughts people?

Regards,

AB

Solution (1)

Accepted Solutions
5 Iridium
12187

Try these:

 

1.  Arrange your desktop icons the way you want them.
2.  Right click on desktop and uncheck View Desktop Items.
3.  Right click on desktop and check View Desktop Items.
4.  Re-boot the system.

 

1.  Right click on the desktop and select View.
2.  Un-check Auto Arrange.
3.  Click Align to grid.
4.  Click Show Desktop Icons.

Drag your Icons to where you want them.

 

Finally, here's a registry trick to lock them in place - but be sure to backup your registry first:

 

"To lock your desktop icons into place, first arrange them the way you want, then open up the registry editor (Start --> Run, and type regedit).

Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.

Right-click in the right pane and select New, DWORD Value name NoSaveSettings and press the Enter key.

Right-click on the new NoSaveSettings item and select Modify. Enter 1 in the Value data box.

 

After this, whenever you restart Windows, your settings will return to their current state."

From experience, I've found that:   “Beauty is in the eye of the beer-holder”!!

 

XPS M1730:

Smoke Grey Magnesium Alloy Chassis - with White LED Backlights
17" UltraSharp WUXGA Widescreen TFT (1920 x 1200) with TrueLife
Intel Core 2 Duo Processor T9300 @ 2.50GHz (800 MHz FSB, 4MB L2 cache)
4GB (2x 2GB) Patriot Signature PC2-5400 @ 667MHz
DUAL 512MB Nvidia 8800M GTX cards in SLi + 128MB Ageia PhysX
640GB SATA II (2x 320GB WD Scorpio Black 7200rpm)
8x Super-Multi DVD±RW
Creative X-Fi Notebook (ExpressCard) + Creative GigaWorks T40 Series II
Integrated 2MP Webcam
Dell Wireless 355 Bluetooth 2.0 Module
Intel Next-Gen Wireless-N Mini-Card
TV Tuner and Dell Travel Remote Control
4-in-1 Flash Card Reader (SSD/MMC/MS Pro/xD)

230W AC Adapter / 9-cell Lithium-Ion Battery

Windows 7 Home Premium (64bit)

View solution in original post

Replies (3)
5 Iridium
12188

Try these:

 

1.  Arrange your desktop icons the way you want them.
2.  Right click on desktop and uncheck View Desktop Items.
3.  Right click on desktop and check View Desktop Items.
4.  Re-boot the system.

 

1.  Right click on the desktop and select View.
2.  Un-check Auto Arrange.
3.  Click Align to grid.
4.  Click Show Desktop Icons.

Drag your Icons to where you want them.

 

Finally, here's a registry trick to lock them in place - but be sure to backup your registry first:

 

"To lock your desktop icons into place, first arrange them the way you want, then open up the registry editor (Start --> Run, and type regedit).

Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer.

Right-click in the right pane and select New, DWORD Value name NoSaveSettings and press the Enter key.

Right-click on the new NoSaveSettings item and select Modify. Enter 1 in the Value data box.

 

After this, whenever you restart Windows, your settings will return to their current state."

From experience, I've found that:   “Beauty is in the eye of the beer-holder”!!

 

XPS M1730:

Smoke Grey Magnesium Alloy Chassis - with White LED Backlights
17" UltraSharp WUXGA Widescreen TFT (1920 x 1200) with TrueLife
Intel Core 2 Duo Processor T9300 @ 2.50GHz (800 MHz FSB, 4MB L2 cache)
4GB (2x 2GB) Patriot Signature PC2-5400 @ 667MHz
DUAL 512MB Nvidia 8800M GTX cards in SLi + 128MB Ageia PhysX
640GB SATA II (2x 320GB WD Scorpio Black 7200rpm)
8x Super-Multi DVD±RW
Creative X-Fi Notebook (ExpressCard) + Creative GigaWorks T40 Series II
Integrated 2MP Webcam
Dell Wireless 355 Bluetooth 2.0 Module
Intel Next-Gen Wireless-N Mini-Card
TV Tuner and Dell Travel Remote Control
4-in-1 Flash Card Reader (SSD/MMC/MS Pro/xD)

230W AC Adapter / 9-cell Lithium-Ion Battery

Windows 7 Home Premium (64bit)

2555

The NoSaveSettings Value (Data) should be 0 not 1 (see https://www.tenforums.com/general-support/15667-desktop-icons-keep-rearranging-11.html 

2 Bronze
2 Bronze
12187

Nice! Love the registry hack. FTR-The desktop aproach worked as well. Sorry for the delay on the thanks.

Regards,AB

Latest Solutions
Top Contributor