MacPro will not recognise or detect my Dell u2711 monitor

My MacPro will not recognise or detect my Dell u2711 monitor.

There is an app called Display Menu, a free utility on the App Store: http://itunes.apple.com/us/app/id549083868

This allowed me to investigate my problem properly.

My problem started when I bought a second hand MacPro to update my older MacPro.
This newer machine is a 2010 MacPro5,1 / 6-Core Intel Xeon, 2.66 GHz / Mountain Lion 10.8.4 / ATI Radeon HD 5870 1024 MB graphics with DVI and 2 mini display ports.

Having set it up on a HP monitor without problems, I thought it would be very easy to plug in my Dell u2711 monitor using the same 'mini display to display port' cable.

Wrong. Nothing - not an electronic sausage, just a blank screen.

Lots of checking of various forum threads, but nothing seemed to work.

Did all the obvious things, the Dell monitor worked perfectly on my old 2008 MacPro (10.8.4) using a Dual DVI cable. This time, I was trying to use the display port using a cable that worked on another MacPro with a similar screen and also on my HP monitor.

Plug in my old HP screen and all is well again, but plug in the Dell at the same time - blank screen on both.

Swopping monitors and doing a restart (Ctrl-cmd-eject) still left me with blank screens, only a full shutdown and restart seemed to restore the HP monitor.

Reset NVRAM, SMC, reboot, swop cables, tried a very old Dell monitor and that didn't work either.

Then I downloaded & tried the Display Menu app. Set up was by using the HP monitor, chose a resolution like 1280x800, and plugged in the Dell along side the HP screen. The screen of the HP monitor immediately cleared, leaving me with just the desktop background image, and the Display Preferences dialogue box.

Woke up the Dell from the power save mode and suddenly I had the desktop revealed. I was able to switch to mirror mode using the Display Menu app.

Unplugged the HP monitor and the Dell continued to work OK. Yeah!

This was not the end of the story however. When the computer was woken from sleep, the Dell again showed a blank screen.

More checking of threads. On this thread I found two suggestions. Set the DDC/CI option to DISABLE, and also unplug the Dell from the mains and reconnect. Other suggestions were that the display port option could be temperamental, and a DVI cable more stable.

Did all that, and changed back to the DVI cable, and this has finally given me the solution.

I will look out for a better quality display port cable, and see if that will work, but for the time being I have it fixed.


Tags (2)
0 Kudos