Highlighted
thezaza101
1 Copper

P2715Q, no image using DisplayPort at resolution 3840x2160@60hz

Jump to solution

I bought a Dell P2715Q and I'm connecting it to my PC using a DisplayPort cable (bought separately, not RBR). The issue basically is that the monitor doesn't display when using 3840x2160@60hz but it does using 3840x2160@30hz. I have also tested the monitor at 2560x1440@60hz which works). When I say 'monitor doesn't display' , I mean that whenever the refresh rate is changed to 60hz, the monitor goes into standby mode. I'm changing the refresh rates using the advanced settings in the resolution selection settings using my second monitor. I've searched the dell website/internet and it seems like multiple people have reported this issue however i have not seen a fix for this issue mentioned. any ideas? 

* What is the 20 digit alpha-numeric monitor serial number?
Serial: CN0GVDF874445553011S
P/N: WJKVX rev.A01

* What specific computer model?
?? – Computer is custom built, monitor in question is P2715Q

* What operating system?
Windows 8.1 64bit

* What video card?
AMD R9 290 (link to model)

* Video card driver version?
14.502 (Catalyst version 15.5) - latest as of 09 Jun 2015

* What video out ports are available on the video card?
1 x HDMI (with 3D)
1 x DisplayPort 1.2
2 x Dual-Link DVI-D

* What video out port are you using from the video card to what video in port on the monitor?DisplayPort

* What cable are you using to attach the video card to the monitor?
DisplayPort

* Press the monitor Menu button to open the monitor OSD (On Screen Display). The bottom of that screen should show a resolution. What is listed?
Resolution : 3840x2160 @ 30hz
Maximum : 3840x2160 @ 60hz

* Was the monitor purchased from Dell or some reseller?
From Dell

1 Solution

Accepted Solutions
thezaza101
1 Copper

RE: P2715Q, no image using DisplayPort at resolution 3840x2160@60hz

Jump to solution

Ok finally got time to test this.

The Dell supplied DP to mDP cable works without problem, and so does the new DP to DP cable i got.

Looks like my original problem was a bad DP cable.

Thanks for your help!

4 Replies
Moderator
Moderator

RE: P2715Q, no image using DisplayPort at resolution 3840x2160@60hz

Jump to solution
0 Kudos
thezaza101
1 Copper

RE: P2715Q, no image using DisplayPort at resolution 3840x2160@60hz

Jump to solution

As far as i am aware an AMD R9 290 can support multiple 4k displays and has a DisplayPort 1.2 output based on info on their website. Also have the latest drivers for the graphics card.

I also checked that MST is off and reset the monitor but it made no difference to the problem I'm having.

I'm getting a VESA certified cable to see if that makes a difference, i cant tell if my current one is. Other suggestions are welcome in the meantime.

0 Kudos
Moderator
Moderator

RE: P2715Q, no image using DisplayPort at resolution 3840x2160@60hz

Jump to solution
0 Kudos
thezaza101
1 Copper

RE: P2715Q, no image using DisplayPort at resolution 3840x2160@60hz

Jump to solution

Ok finally got time to test this.

The Dell supplied DP to mDP cable works without problem, and so does the new DP to DP cable i got.

Looks like my original problem was a bad DP cable.

Thanks for your help!