1 Copper

S2417DG, GTX 1080, change to 144Hz


I have just purchased a S2417DG monitor. When I try to change to 144Hz, the monitor switches to power saving mode and then resets to the frequency it was at previously. The highest I can currently get it is 85Hz. In the monitor menu, it shows that the Maximum settings are 2560x1440, 144Hz. My graphics card is an EVGA GTX 1080 and I am using a DP connection.

Tags (2)
0 Kudos
1 Reply

Re: S2417DG, GTX 1080, change to 144Hz


For my notes, send me via Private Message the S2417DG service tag number and 20 digit serial number.

Installation =
* Download and install the S2417DG Windows 10 driver
* Uninstall the GeForce Experience
* Restart the PC when done
* Download/Save the latest Nvidia WHQL G-SYNC compatible driver to your Windows Desktop
* Right click the file and select "Run as administrator"
* Click OK
* Click Agree and Continue
* Click Custom (Advanced)
* Click Next
* Check the following =
Graphics Driver
3D Vision Controller Driver
3D Vision Driver
HD Audio Driver
PhysX System Software
Perform a clean installation
* Click Next
* When done, click Restart Now

* Open the Nvidia Control Panel
* Open Display
* Click Setup G-SYNC
* Check Enable G-SYNC
* Insert the dot to, "Enable G-SYNC for windowed and full screen mode"
* Click Apply
* Open 3D Settings
* Click Manage 3D Settings
* Click the Global Settings tab
* Open Monitor Technology
* Choose G-SYNC
* Click Apply
* Go to Change resolution
* Click the dropdown to 144Hz
* Close the the Nvidia Control Panel

* Right click the Desktop
* Click Display Settings
* Click Advanced Display Settings
* Click Display adapter properties
* Click the Monitor tab
* Change to 144Hz
* Click Apply- OK

0 Kudos