Highlighted
Carter7708
1 Copper

S2716DGR, GTX 1080, can’t run above 85Hz

So I bought the monitor yesterday, but it won’t run above 85Hz refresh rate. Whenever I try to adjust the refresh rate above 85Hz on either display setting or Nvidia control, the monitor just goes black and says “entering power saving mode”, until 20 seconds later when the setting automatically switch back to 85Hz. I made sure to use the display cord that comes with the monitor, tried all three display cord outlets on my computer, updated my driver with Nvidia and installed the driver for the monitor, unplugged power and waited, switched between power strip and wall power outlet, reset to factory setting and turned off deep sleep mode on monitor, but it still doesn’t work. I tried the monitor at my friend’s computer and it worked fine. And I tried my friend’s 144Hz monitor with my computer and it also worked fine. But my own monitor won’t run above 85Hz on my computer. I have a GTX 1080 graphic card, 16 ram, Windows 10.I don’t know what I should do?

0 Kudos