Highlighted
cherty
1 Copper

U2518D, ThinkPad hub, can't select 2560x1440 on 2nd monitor

I have a lenovo carbon running windows 10.  The lenovo is connected via the power/video out cable to a thinkpad hub.  the hub is connected to each monitor via separate DP to DP cables.  I also tried the DP to mini DP (with mini DP going into the monitors).  No matter how I configure it, one of the monitors works perfectly with 125% sizing and 2560x1440, both of which are "recommended".  The other monitor, however, does not show the same recommended sizing or resolution.  instead it shows 100% recommended, and does not have 2560x1440 as an option - i can only select 2048x1080.  I have tried several different configuration.  has anyone experienced this issue? any suggestions?

Tags (2)
0 Kudos
3 Replies
swamped207
2 Iron

Re: U2518D, ThinkPad hub, can't select 2560x1440 on 2nd moni

0 Kudos
Moderator
Moderator

Re: U2518D, ThinkPad hub, can't select 2560x1440 on 2nd moni

 

I would first take the hub out of the troubleshooting equation. Test each monitor by itself directly to the laptop. If both monitors do the maximum 2560x1440 60Hz, then we know that the monitors and laptop are functioning correctly. Then look to the hub as the culprit and troubleshoot from there.

0 Kudos
NC Low
1 Copper

Re: U2518D, ThinkPad hub, can't select 2560x1440 on 2nd moni

Finally, I have successfully extended to my 2nd display(Dell U2518D). I intent to connect 2 external monitors without even opening my laptop. I couldn't even extend one monitor. Could'nt get solution from dell's and lenovo's communities.

 

Let me share my experience.

Below is my setup:

X1 carbon -> Thinkpad onelink Pro -> Dell U2518D

 

I am using windows 10. This is the behavior i experienced. Right click and select windows 'display settings' -> 'select and rearrange display', only '1' monitor is displayed. Under windows 'display settings' -> 'advance display setting'  it shows monitor brand and model perfectly. Select under 'multiple displays'-> 'extend these displays',  windows extends it but monitor still does not receive signal or lit up.

 

Initially, I thought it is due to the onelink pro(thinkpad hub) as direct cable connection worked from my laptop's hdmi port/display port to monitor but this does not utilities my onelink pro. I proceeded to update laptop's latest bios and drivers and it does not work still.

After some troubleshooting, It finally worked when i installed the dell's monitor firmware update, dell display manager and driver; https://www.dell.com/support/home/us/en/04. So just have to work from your monitor's perspective. If using another monitor brand or model, try to download the respective firmware and drivers.

 

Like if this works for you.

0 Kudos