adc987
1 Copper

RE: DELL U2713HM not USB 3.0

I'm just setting up a new U3014 and have exactly the same problem. The montior claims to be USB 3.0, I plug it into a known USB 3.0 port on the computer, and when I use a USB 3.0 device, I get the "this device can perform faster..." message.

Still digging for answers.

ADC

0 Kudos
ashetosvlakas
1 Copper

RE: DELL U2713HM not USB 3.0

I also purchased the U2713HM and connected the USB 3.0 hub to a RENESAS uPD720200 usb 3.0 controller with the latest firmware on (3.0.3.4). My observations are the following:


1. All my USB 2.0 devices seem to work OK, even HDDs that are USB powered.

2. USB 3.0 devices are a hit and a miss. One USB flash drive I used seems to work correctly. The one USB 3.0 HDD I used behaves in a strange manner. Some times it's not recognised at all. Some times it's recognised but it's unmounted after a minute or so since it works with ultra low speeds and disconnects. And one time I got it to work correctly! This behaviour is the same in both Windows and Linux. Booting with the USB 3.0 HDD connected hangs the system until I remove the HDD. So that makes 3 environments that can't handle the USB 3.0 HDD (BIOS, Windows, Linux). Note that the HDD works fine on the USB 3.0 controller, it is problematic only when it is on the monitor hub.

I would hope for a fast temporary solution that at least makes the USB 3.0 devices work in USB 2.0 speeds as a fallback. But of course, it should work correctly as a USB 3.0 hub.

0 Kudos
Moderator
Moderator

RE: DELL U2713HM not USB 3.0

ashetosvlakas,

For my notes, Click Here, then click "Send a Private Message". Provide to me the following information -
Monitor Service Tag number:
Monitor 20 digit alphanumeric PPID serial number:

0 Kudos
Hu-Bo
1 Copper

RE: DELL U2713HM not USB 3.0

If you think about, it the fact that the 3.0 flash drive seems to work ok but not the 3.0 HDD it would seem to be a power issue. I gave up on using my monitor ports. The monitor looks so good that I can live with it as is. I may buy a highly reviewed  3.0 hub, the Plugable 4-Port SuperSpeed USB 3.0 Hub. It has upgradeable firmware. I don't think that USB 3.0 is fully developed yet.

0 Kudos
Moderator
Moderator

RE: DELL U2713HM not USB 3.0

0 Kudos
ashetosvlakas
1 Copper

RE: DELL U2713HM not USB 3.0

Both USB 2.0 and USB 3.0 HDDs I tested are USB powered by Y-cables. I'm pretty sure the monitor can supply plenty of power to devices because the USB 2.0 HDD is very power hungry, and it works perfectly fine on the monitor hub. We're talking about a very old USB 2.0 HDD that doesn't work if you plug it in front panel ports, it needs all the power you can provide. This same USB 2.0 HDD works fine on the monitor hub, whereas the USB 3.0 HDD that uses something like half the power (south of 2.5 Watts) doesn't work.


Maybe it's a problem of negotiating higher power states for USB 3.0. If the monitor can power the USB 2.0 HDD then it certainly can power the USB 3.0 HDD as well, even by using USB 2.0 power states instead of using the USB 3.0 higher power state.

About the Monitor Service Tag number and PPID serial number I will try to give them to you when I get home.

0 Kudos
Moderator
Moderator

RE: DELL U2713HM not USB 3.0

When the monitor USB upstream cable is connected to the computers USB 3.0 port, the monitor downstream ports provide -
0.9amps, 5volts, 4.5watts

0 Kudos
ashetosvlakas
1 Copper

RE: DELL U2713HM not USB 3.0

I just found a way around the problem for my monitor, maybe it can be of help to all people here. The manual clearly states "This section gives you information about the USB ports that are available on the left side of your monitor" when talking about the downstream USB 3.0 ports specifications. I made the observation that the downstream ports on the left side are further away from the power supply of the monitor and decided to compare USB 3.0 behaviour with the downstream ports on the BACK of the monitor.

The conclusion was that the USB 3.0 HDD ALWAYS works with the downstream ports on the back of the monitor, and ALMOST NEVER works with the downstream ports on the left of the monitor.

I don't know the explanation for this, maybe the manual is wrong, maybe it is something else, but feel free to test this and compare results!

0 Kudos