Highlighted
pragmat1c
1 Nickel

U3415W - USB HUB and Peripherals Issue

I'm using the U3415W to share multiple peripherals between two computers.

I've been experiencing a problem with a few of the peripherals and this hub.

Issue One:

The peripheral just stops working. This is the most pronounced with keyboards and headsets. The peripheral will just stop working. I have to unplug it plug it back in again.

Issue Two:

Keys will be repeated many times (10-20+) 

I've tried multiple keyboards, same issue.

I tried plugging my peripherals into another hub and they work without issue.

Is there anything I can do with the built in hub? Is there any firmware update or anything else I can try?

0 Kudos
3 Replies
Moderator
Moderator

RE: U3415W - USB HUB and Peripherals Issue

What is the state (on/powersave/hibernate) of the computers when you toggle back to them using the monitor?

You need to set all USB powersave options to Off on both computers and retest.

There are no customer accessible firmware updates.

0 Kudos
pragmat1c
1 Nickel

RE: U3415W - USB HUB and Peripherals Issue

> What is the state (on/powersave/hibernate) of the computers when you toggle back to them using the monitor?

Power on. This issue happens while i'm working on a _single_ computer all day. Not even switching between them. (I'm just explaining why i have my peripherals plugged into the hub.)

> You need to set all USB powersave options to Off on both computers and retest.

I've done this on the machine I'm having problems with and it didn't seem to help.  I need to restart everything, laptop, pc, monitor and see if there is any change. I'll try to find the time to do this (I use this for work) and test it for a while and report back.

0 Kudos
pragmat1c
1 Nickel

RE: U3415W - USB HUB and Peripherals Issue

> You need to set all USB powersave options to Off on both computers and retest.

This appears to be the answer. The machine with the issue is a macbook pro running Windows 10 (company machine).

In Windows 10 in the Power Options dialog, USB Settings > USB selective suspend setting > Plugged in, i changed it to "Disabled".

This seems to have fixed the issue. (Its seem to have taken effect once i rebooted).

0 Kudos