Vidda911
2 Iron

Backup failed on active Exch DB, when reseeding running.

Jump to solution

Hello everybody,

My Exchange backup works fine since many weeks.

The admin exchange decide to enlarge the volume of disk DB.

And when the DB are reseeding, the backup hang.

My question:

Is it possible to backup active DB, when the exchange server is reseeding the passive DB ?

Is it possible to backup active DB, when the passive DB are not healthy ?

(The error is VSS_E_WRITERERROR_RETRYABLE, etc....)

Thanks

David.

0 Kudos
6 Replies
CarlosRojas
4 Germanium

Re: Backup failed on active Exch DB, when reseeding running.

Jump to solution

Hi David,

Definitely is not possible to backup the passive DB is this one is not healthy, even if you bypass the checks (Jet errors and consistency check), NMM will detect the inconsistency of the DB and backup will fail.

About the reseeding, theoretically the backup should work fine, as the Active DB always contains the latest and most up to date information and logs, so backup should work, however, if there is an issue with the replication (you can see those in the Application and Exchange event logs) then backup will most likely fail for this reason.

So basically Replication has to be 100% healthy so the backup can proceed, as NMM will prevent to run any successful backup if Replication is not ok in DAG environments (for Exchange 2010) and SCC, LCR and CCR environments (for Exchange 2007).

Thank you.

Carlos.

0 Kudos
Vidda911
2 Iron

Re: Backup failed on active Exch DB, when reseeding running.

Jump to solution

I have contacted the support guys, and they say:

When Exchange seeding, no backup it's possible.

I will test a backup without the DB that reseeding.

0 Kudos
Highlighted
CarlosRojas
4 Germanium

Re: Backup failed on active Exch DB, when reseeding running.

Jump to solution

Hi David,

Answer refers to both, active and passive DB's?

I would partially agree with that answer.

For passive DB I could understand that backup will fail.

For Active DB I could understand that backup would fail if there are events (errors or even warnings) for the reseeding process, but if reseeding process is running and going well, with no failure or alerts, then backup should work fine.

Anyway, let us know how the backup goes.

Thank you.

Carlos.

chybowskig
1 Copper

Re: Backup failed on active Exch DB, when reseeding running.

Jump to solution

hi,
Can you tell us how big is the DB?
I have a similar problem.
I can not do backup databases larger than 110GB, logs are cut. The next databases beyond this size is no longer backuped.

I'm also in many other databases, which are smaller and the correctly-archive.

Maybe something like this help, do you think???

http://www.symantec.com/business/support/index?page=content&id=TECH135465

Greg

0 Kudos
CarlosRojas
4 Germanium

Re: Backup failed on active Exch DB, when reseeding running.

Jump to solution

Hi Greg,

Based on the description of your issue (backing up large DB's) I think you should first apply the following changes on NetWorker server and clients:

To avoid timeouts please do as follows in NetWorker and Exchange servers:

  

1.- Group Inactivity Timeout is set to "0" in the Exchange client configuration in NMC.

  

2.- Add the TCP/IP settings as described in the article above, and if it still fails I would suggest to add the following values in Client and Server:

  

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpWindowSize=256000

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\GlobalMaxTcpWindowSize=16777216

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\KeepAliveInterval=1000

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\KeepAliveTime=600000

  

On Solaris:

  #ndd -get /dev/tcp tcp_keepalive_interval

  

7200000

  

#ndd -set /dev/tcp tcp_keepalive_interval 3360000

Also disabling TCP Chimney is a good approach, however there was a new MS KB that encourage the use of TCP chimney:

KB912222

and

KB982383

However I would say that without applying any hotfix or changing anything in the TCP Chimney just changing the values in the registry and setting timeout to = in the group should fix your issue.

Thank you.

Carlos.

0 Kudos
chybowskig
1 Copper

Re: Backup failed on active Exch DB, when reseeding running.

Jump to solution

Thank you Carlos, you were right.

I added entries for Networker server (Win2003)

"2.- Add the TCP/IP settings as described in the article above, and if it still fails I would suggest to add the following values in Client and Server:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\... "

backup is performed correctly, as it is in the book

Thank you again Greg

0 Kudos