JohanRM
3 Silver

Backup of share on NETAPP does not work anymore

Hi,

So far, i could backup 2 shares using NDMP protocol on my Netapp running Clustered Ontap 8.3.

I don't know what happens but i can't backup my NETAPP sahers anymore. I can still backup savesets on windows servers.

The savestes are specified as /vs_cifs/Vol1/savesetname where vs_cifs is a SVM on the NETAPP.

When i start a group, a tape is loaded, the savesets enter into the currently running field and then i see in the NMC: ready for writing on the mounted tape. But than nothing happens anymore.

In the remote field of my NETApp client (which is node), there  is a field admin with a password. I don't know how to generate anymore.

I tried:

vserver services ndmp generate-password -vserver sith-cluster -user admin

but also with:

vserver services ndmp generate-password -vserver vs_cifs -user admin

Both of this command generated a password but when i enter the value in that field of the remote user, i get an autorisation error.

How can i get backup the corretc password for the remoet admin user.

I check in the vs_cifs SVM on the NETAPP and the user admin did not even exist.

Any idea how i can fix this ?

Best regards,

Johan

0 Kudos
6 Replies
JohanRM
3 Silver

Re: Backup of share on NETAPP does not work anymore

Hi,

The password is not the problem, i was successfull to generate the corerct password with the command:

vserver services ndmp generate-password -vserver sith-cluster -user admin

i then created a new client with the wizard and that so far i was successfull.

I than started a newly created group and launched a backup.

It loads a tape of the correct pool and than stays in the state: ready for writing idle              (as i can see in the NMC nexto tape drive where the tape is loaded.)


What could be wrong here ?

Best regards,

Johan

0 Kudos
ble1
7 Thorium

Re: Backup of share on NETAPP does not work anymore

Check logs on NetApp side.  I know when I tried SVM based it didn't work for me so I used node based backup.  I don't recall the specifics why SVM didn't work, but it might be that at that time SVM was not supported by version of NW I run (right now I run 8.2.2.x and still use node based approach).

0 Kudos
JohanRM
3 Silver

Re: Backup of share on NETAPP does not work anymore

It worked until last week.... using NW 8.2.1.0- build 681.

0 Kudos
ble1
7 Thorium

Re: Backup of share on NETAPP does not work anymore

Then probably something must have changed on NA side.  Check the logs there and see if perhaps active node has changed or something like that.

0 Kudos
JohanRM
3 Silver

Re: Backup of share on NETAPP does not work anymore

I will check the ndmp.log file

0 Kudos
Joe_chang
2 Bronze

Re: Backup of share on NETAPP does not work anymore

NetWorker uses RPC for client server communication, the symptom you got "ready for writing idle" indicates the communication didn't complete its full authentication. Common cause for this scenario is the export name somehow resolved differently than the initial handshake path. To prove this it's easy, check netstat output, port 10000 (NDMP) is the RPC port NW would use for communicating with the client. I suspect the problem is that the connected IP does't match with the IP bond to interface name of export.

HTH,

0 Kudos