jeremylc
1 Nickel

Error fetching vCenter information, SOAP v1.1 timeout

NetWorker 8.2.1.3.Build.774

VBA 1.1.1.50

WMware 5.5

ESXi 5.1

(Please note: This is an initial deployment, so it didn't just stop working, it has yet to work)

I'm getting an error when trying to access the VMware View in NetWorker (8.2). I have two vCenters, and only one of them works, the other gives the following error:

Error fetching vCenter information

vCenter: <vcentername>

Reason(s): Remote process exited with errors

So, on the NetWorker server I did the following:

dbgcommand -p <nsrvmwsdpid> Debug=99

then try to refresh the VMware View. I find the following error in the daemon.raw

106637 1435326979 1 3 0 300 5336 0 <networker_server> nsrdisp_nwbg RAP notice 33 job 'nsrvim' progress message: %s 1 0 236 SOAP FAULT (v1.1) A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

What's weird, though, is that if I run the following command manually while the VMware View is refreshing(*)  the VMware View shows all the VMs from both vCenters.

PsExec.exe -s 'C:\Program Files\EMC NetWorker\nsr\bin\nsrvim.exe' -s <NetWorker Server> -D99 -v -d --names <vCenter Server>

The VBA is installed and registered. I went through the process outlined in this post

VMware view generates Error fetching vCenter information

and verified the password I have stored for my vCenter user account, and it is the same account for both the working and the non-working vCenter.

I might suspect a networking issue (latency?), but the NetWorker server is on the same subnet, VLAN, and physical switch as the vCenter.  They can communicate over the network.

*) PsExec is from SysInternals, '-s' lets the command run as the local 'SYSTEM' account, which is how the NetWorker service runs.

4 Replies
TimH2
2 Iron

Re: Error fetching vCenter information, SOAP v1.1 timeout

0 Kudos
jeremylc
1 Nickel

Re: Error fetching vCenter information, SOAP v1.1 timeout

I've already verified the username and password within the NSR Hypervisor. The second link is a similar, but not the same problem.  As I said, if I click "refresh" on the VMware View then run the above nsrvim command manually on the NetWorker server while it is refreshing it will actually show the VMs from both vCenters.  The problem appears to be some kind of premature timeout when the NetWorker is trying to connect to the vCenter.

0 Kudos
RWinter1
1 Copper

Re: Error fetching vCenter information, SOAP v1.1 timeout

Have you managed to solve this? I think im facing the same error

0 Kudos
jeremylc
1 Nickel

Re: Error fetching vCenter information, SOAP v1.1 timeout

Nope. I never found a resolution. Even after upgrading all the way to 8.2.3 I still get the same error in the NMC.

0 Kudos