Highlighted
Cade Robinson
1 Nickel

Inventory when depositing a tape?

I upgraded from Networker 8.2.2.5 to 8.2.3.1 and everything is working great - except one thing.

When I deposit a tape from the import ports it used to inventory them automatically.

Now they don't and I have to manually inventory them.

Fast inventory (-II) fails and a normal inventory loads the tape into the drive.

Is this something that changed in 8.2.3.1 or is something messed up with my media DB?

0 Kudos
6 Replies
bingo.1
4 Tellurium

Re: Inventory when depositing a tape?

The reason could be the introduction of the new media db (SQLite replaces WISS).

It it possible that such is just an unique extra verification.

Let me suggest you withdraw and re-reposit a known tape. Maybe NW then will behave 'the old way'.

0 Kudos
bingo.1
4 Tellurium

Re: Inventory when depositing a tape?

What also came into my mind is a new option for the jukebox resource which is set by default.

0 Kudos
Cade Robinson
1 Nickel

Re: Inventory when depositing a tape?

I thought that too - that an unload and reload would get it sane. Not so much.

ndbku01:~ # nsrjb -S 2

Jukebox ndbku01: (Ready to accept commands)

slot  volume       pool    barcode  volume id        recyclable

   2: 000002(R)    1Month  000002   2751505714       yes      

ndbku01:~ # nsrjb -S 2 -w -P 1

05/25/16 08:22:11.082627 Info: Operation `read elements status' is in progress on jukebox `ndbku01'.

05/25/16 08:22:11.082777 Info: Moving media from slot 2 to port 1.

05/25/16 08:22:11.082808 Info: Withdrawing 1 cartridges.

05/25/16 08:22:11.082834 Info: Remove any cartridges from the ports.

Jukebox operation finished with status: succeeded

ndbku01:~ # nsrjb -S 2 -d -Y -P 1

05/25/16 08:24:17.431167 Info: Operation `read elements status' is in progress on jukebox `ndbku01'.

05/25/16 08:24:17.431338 Info: Moving media from port 1 to slot 2.

05/25/16 08:24:17.431370 Info: Depositing 1 cartridges.

Jukebox operation finished with status: succeeded

ndbku01:~ # nsrjb -S 2

Jukebox ndbku01: (Ready to accept commands)

14119:nsrjb: No volumes labeled.

slot  volume  pool  barcode  volume id  recyclable

   2: -*            000002   -                   

        *not registered in the NetWorker media data base

ndbku01:~ # nsrjb -I -S 2

05/25/16 08:30:14.647450 Info: Updated volume `000002' in slot 2.

05/25/16 08:30:14.647590 Info: Operation `Eject' in progress on device `/dev/nst4'

Jukebox operation finished with status: succeeded

ndbku01:~ # nsrjb -S 2

Jukebox ndbku01: (Ready to accept commands)

slot  volume       pool    barcode  volume id        recyclable

   2: 000002(R)    1Month  000002   2751505714       yes

0 Kudos
ble1
5 Iridium

Re: Inventory when depositing a tape?

Try also 8.2.3.2.  I personally never used withdraw and deposit via nsrjb (I always used sjimm and then I would reset and quick inventory lib).

0 Kudos
Cade Robinson
1 Nickel

Re: Inventory when depositing a tape?

Just updated to 8.2.3.2 and didn't help.

0 Kudos
StuartWhitby
1 Nickel

Re: Inventory when depositing a tape?

I'd raise a case for this one.  NetWorker engineering seem to have lost focus on tape libraries and it's quite possible that this is simply some kind of oversight in the interaction between nsrjb and the new media db in 8.2.3.

0 Kudos