Matt7125
2 Bronze

NDMP backups failing with 2008 Server

I'm in the process of configuring ndmp backups on some new equipment and upgraded software and cannot seem to get NDMP netapp backups to run.   The new system is running Server 2008 r2 with NW 7.6.2.  All non-NDMP backups are running fine.  The old system running server 2003 with NW 7.3.2 runs NDMP netapp backups without any problems.  I've basically copied the configuration from the old server to the new server but continue to get the following errors below almost immediately after starting backups.  Your help is much appreciated.

savegrp: suppressed 2 lines of verbose output

42794:nsrndmp_save: Performing backup to Non-NDMP type of device

42658:nsrdsa_save: DSA savetime = 1326140424

42909:nsrndmp_save: Performing DAR Backup..

83563:nsrndmp_save: Performing full backup, BASE_DATE = 0

Host = 'New 2008 server name' (172.X. X.X) port = 8644

42597:nsrndmp_save: data connect: failed to establish connection

42886:nsrndmp_save: Unable to start the NDMP backup process.

nsrdsa_save : Aborted

42913:nsrndmp_save: Save session closed with NW server successfully

0 Kudos
3 Replies

Re: NDMP backups failing with 2008 Server

Hello Matt,

                           you can refer following  kb article which gives the resolution of the issue  for the error message "nsrndmp_save: data connect: failed to establish connection"you have provided.

http://solutions.emc.com/EMCSolutionView.asp?id=esg117173&usertype=C

Thank you,

Vishwanath K

0 Kudos
ble1
6 Indium

Re: NDMP backups failing with 2008 Server

I had pretty much same issue and this is NW problem - at least in my version of the event.  What happened was that I have backup server on VLAN A, B and C.  I have 4 storage nodes; 2 of them in VLAN A and B and two of them in VLAN C and D.  VLAN B can talk to VLAN D.  My NetApp filers are on C and D.

A is primary (management) in old network config, B is used for backup/NFS traffic.

D is primary in new network config and C is used for backup/NFS traffic.

Originally I wanted to use storage node in new network setup (C and D) and have backup going over C VLAN.  Everything was configure by the book, but had the same error as you.  On more detailed examination, I found that nsr_dsasave is spawned with -s A which breaks the thing.  And there is no way in NW config to change this (server interface, some known and unknown switches, etc).  So, at the end I modified host table on storage node in new network config and made fake entry where I used IP of VLAN C against name of VLAN A.  That worked finally.  This is not elegant solution and hopefully EMC folks will fix it as this sort of workaround might not be everyone's cup of tea.

0 Kudos
skvenkateshan
1 Copper

Re: NDMP backups failing with 2008 Server

Just for record purpose for people trying to find answer, follow below KBs. IP address used should be IPV4 on the networker

https://support.emc.com/kb/420975

https://support.emc.com/kb/424647

https://support.emc.com/kb/323108

Application commands added are below

USE_TBB_IF_AVAILABLE=Y

EXTRACT_ACL=T

DIRECT=Y

BUTYPE=dump

HIST=Y

UPDATE=Y

/"SVM name"/"netapp volume junction name"

0 Kudos