goldrake1
1 Nickel

NSRSNMD failed to start

Jump to solution

Hi

I have a new installation of NW 8.01 build 132 evaluation. The physical

server has a tape library attached and it will be used later. When I try to

add an AFTD (local storage-a directory on local disk on my server) with a

new device wizard I received an error: Failed to start nsrsnmd on host

"myserver", error The Networker server is not authorized to start nsrsnmd

on this storage node.

Any ideas?

regards

Fausto

0 Kudos
1 Solution

Accepted Solutions
Hariprakash1
1 Nickel

Re: NSRSNMD failed to start

Jump to solution

Hi,

Can you Verify the entries of servers file under "Networker_Install_Path\nsr\res"

Makesure there is an entry for the networker server name & restart services on the Server.

HTH Regards

Hari Prakash.

0 Kudos
11 Replies
RFreund1
1 Nickel

Re: NSRSNMD failed to start

Jump to solution

Assuming the storage node software is installed, make sure that this machines listens to the right NW server.

Verify that the file ..\nsr\res\server has the correct entry listed.

If you have to edit the file, you must restart the NW client listener (nsrexecd) to 'register' the change.

0 Kudos
goldrake1
1 Nickel

Re: NSRSNMD failed to start

Jump to solution

Hi

The file has the correct entry. What do you mean that the storage node

software is installed? Under devices >storage nodes my backup server is

listed and a library with two tape drives also. What else to check?

Regards

Fausto

0 Kudos
bingo.1
4 Tellurium

Re: NSRSNMD failed to start

Jump to solution

Basically, a NW host may have one of these core functionalities. However, these packages must be installed to achieve that:

1. Client                              Client Package

2. Storage Node                  Client Package + Storage Node Package
3. Server                             Client Package + Storage Node Package + Server Package

On a Linux/UNIX system you will find these packages when you grep for 'lgto'.

On Windows, it is not so easy to figure out. Worst case you need to rerun the installation process.

0 Kudos
goldrake1
1 Nickel

Re: NSRSNMD failed to start

Jump to solution

The package installed is Server and Client. Storage Node should be

included. I have windows installation. Can be an administrator rights

problem?

0 Kudos
Highlighted
RFreund1
1 Nickel

Re: NSRSNMD failed to start

Jump to solution

You are correct - as the server is also a storage node, this package is included (the selection screen is somehow misleading).

O.K. - so this is a single server with no remote storage nodes.

No, the rights should not be an issue because the services use the SYSTEM account.

As we don't know how you configured your device, it is hard to say what is going wrong. To avoid an potential issue, may i suggest that you define the device the old-fashined way without the wizard.

Just state:

   Name:  <absolute_path_name_to_your_directory>

   Device access information  <absolute_path_name_to_your_directory>

   Media type: adv_file

That's it.

This should define your new device. Then label it and off you go ...

0 Kudos
goldrake1
1 Nickel

Re: NSRSNMD failed to start

Jump to solution

I have defined manually a new device but at verify valid path the error

is:"Storage node is not ready". I received the message Failed to start

nsrsnmd on host....every two minutes regardless the configuration of

adv_file

regards

Fausto

On Fri, Jul 12, 2013 at 11:23 AM, Ida Socca

0 Kudos
Hariprakash1
1 Nickel

Re: NSRSNMD failed to start

Jump to solution

Hi,

Can you Verify the entries of servers file under "Networker_Install_Path\nsr\res"

Makesure there is an entry for the networker server name & restart services on the Server.

HTH Regards

Hari Prakash.

0 Kudos
goldrake1
1 Nickel

Re: NSRSNMD failed to start

Jump to solution

Hi Prakash

I have resolved the issue. There was a mistake in the server name. Thanks

Fausto

On Thu, Aug 1, 2013 at 8:55 AM, Hariprakash

0 Kudos
sritam35
1 Copper

Re: NSRSNMD failed to start

Jump to solution

Hi..

I got this same error in one of my storage node windows 2008 client having Networker 8.0.1.4.Build.163 . This is a single node cluster and i have a remote tape device attached to this client. From the Netowrker side the Storage node is not coming to ready state or it it is keep on going to not ready sate if the SN is enabled and throwing the same error after every 2 mins that "Failed to start the nsrsnmd on host...".

I have checked the servers file of client which is absolutely fine and tried with restarting the services also.

do i need to upgrade to 8.1.1 ? any ideas..

0 Kudos