Highlighted
2 Bronze

NW 7.5 picks tapes at random

After upgrading from 7.3 to 7.5 NW now picks the tapes at random.

I have a HP 4048 tape unit wit 4 drives and 48 slots.

Usually it starts with slot 1 and then 2 and soforth.

Now it picks any tape and when thats full it doesn't pick the next one but a totally random other tape.

Anyone seen this before? Or know the solution?

It wrecks my tapeadministration.

Right now I use NW 7.5.3.2

OS = HP-UX 11v2

0 Kudos
10 Replies
Highlighted
3 Argentum

Re: NW 7.5 picks tapes at random

Networker does not select tapes in numerical order, it follows a set of rules to determine which tape it will use next.  Networker should prioritise the oldest labelled tapes first.  It should not affect the backups in anyway.  You say it wrecks your tape administration but it is very difficult to control sequential use of tapes, particularly when tapes begin to be recycled at different times.  Perhaps you could share with us what your current system is?

0 Kudos
Highlighted
2 Bronze

Re: NW 7.5 picks tapes at random

That's strange. From NW 4 to NW 7.3 it always picked in a sequential way.

I have 48 slots.

When I put in the recycled tapes, I label them from slot 1 to 48 or when not all are used, start with the first unlabeled. (Usually slot 3 or 4)

I can understand, with large libraries, that it doesn't matter which tape it picks.

But I have to change them out every week. So that's why sequential tape picking is something I would want.

0 Kudos
Highlighted
3 Argentum

Re: NW 7.5 picks tapes at random

NetWorker uses a specific logic when it needs appendable tapes, there is nothing loaded in the drives, and there seems to be "identical" tapes to choose from.  Essentially, it will pick older tapes over newer tapes.

Still...

If you are using storage nodes, please make sure that the server and storage nodes are at the same version and patch level.

If you stil think it's picking new tapes over old ones, then open a support ticket.

0 Kudos
Highlighted
3 Argentum

Re: NW 7.5 picks tapes at random

Turns out that there is a bug that affects how tapes are being selected.

The bug NW119432 was found in n/w 7.5.3.2 and is fixed in the latest cumulative install kits.

Bug number NW119432

Fixed in the latest cumulative release.  Please download the latest install kaits at:

ftp://ftp.legato.com/pub/NetWorker/Cumulative_Hotfixes/7.5/

Remember that the server and storage nodes should be running the same version.

Highlighted
7 Thorium

Re: NW 7.5 picks tapes at random

Wallace Lee wrote:

Remember that the server and storage nodes should be running the same version.

In pre 7.3.x days that used to be standard.  Since then, EMC stated that it would support combinations server and sn being different for one service release.  It was even documented.  Did that changed again?

0 Kudos
Highlighted
3 Argentum

Re: NW 7.5 picks tapes at random

I don't know if it was ever documented that the server and storage nodes be same, at one version difference, or running at any different (but support) version.

For me, it just makes sense that the server and storage nodes have the same version.  This prevents the possibility that there are functional difference between the versions causing issues.  Remember: the common processes between the server and storage nodes are: nsrexecd, nsrmmd, nsrlcpd, to name a few, but these, in my opinion, are the critical ones.

Even one major or minor version difference could cause problems.  For example, if nsrd talks to nsrmmd in one way, but nsrmmd talks in a different way.

One practical example: nsrmmd on a storage node 7.6.x will not work with server 7.5.x.

Keeping them at the same version just eliminates the possibility of compatibility differences that could cause problems.

0 Kudos
Highlighted
2 Bronze

Re: NW 7.5 picks tapes at random

Implemented the fix and it looks OK.

Even the minor problem of not accessing an appendable tape, is fixed.

0 Kudos
Highlighted
2 Bronze

Re: NW 7.5 picks tapes at random

Thanks for all the helpful comments and pointing to the fix

0 Kudos
Highlighted
2 Bronze

Re: NW 7.5 picks tapes at random

I saw this ,,post i believe no one consider the way of labeling the tapes.    OK ..  IF you want Networker to take the Volumes one by one in order..  the procedure is simple.     Select all the tape you need to label..   and   the select a drive,     and do Labeling using this Drive Only....  YES..     it take time to label  set of tapes  using single drive..  but the  time stamp of labeling will be different on all the tapes....  ..................................  so when  backup starts  Networker Picks  Tapes  One by One .... cheers.......

0 Kudos
Highlighted
4 Germanium

Re: NW 7.5 picks tapes at random

Sayed,

I don't agree 100% with your comment, as the timestamp will be different in all tapes, regardless of the device used, and I don't think there will be more than one tape labeled at the exact same time, so timestamp will always be different.

Thank you.

Carlos.

0 Kudos