Highlighted
karelkunz
1 Copper

Networker 8.0.3 disabled savegroup duration keeps incrementing

Hello,


I am reaching out for feedback and advice on how to deal with the following phenomenon:

Our client is running Networker server 8.0.3 (Build 342) and although the Default group has been disabled since March 24, 2014, and it does not contain any clients, its duration keeps on incrementing (refer to the attached PDF screenshot please).

While this behavior does not seem to be causing any errors or disruptions to the backups, I would like to learn why it's happening and what steps to take to stop it.


I'll appreciate your feedback and guidance.


Regards, Karel

0 Kudos
8 Replies
bingo.1
4 Beryllium

Re: Networker 8.0.3 disabled savegroup duration keeps incrementing

The only idea I have is a savegrp command which still works in the background since more than a quarter but has never really ended. Later changes of the resources would just become effective if the group is started again.

So use the command line, search the savegrp command and kill it using 'jbkill' or a process explorer.

Of course a restart of the NW daemons/services would also help. But before you restart them, make sure that all processes will be terminated.

0 Kudos
crazyrov
4 Tellurium

Re: Networker 8.0.3 disabled savegroup duration keeps incrementing

Have you tried renaming the tmp and jobsdb yet ? if not please do so and check results.

0 Kudos
karelkunz
1 Copper

Re: Networker 8.0.3 disabled savegroup duration keeps incrementing

I am sorry to say, but your recommendation has not stopped the Default group from “ticking up.”

It’s still adding hours and days to its duration, as if it has been running since March 23, 2014.

Thank you, Karel

0 Kudos
ble1
6 Indium

Re: Networker 8.0.3 disabled savegroup duration keeps incrementing

Karel,

Is that group disabled?  If not, do following:

- disable group

- stop NW

- do this cleanup thing with tmp and jobsdb

- start NW

0 Kudos
karelkunz
1 Copper

Re: Networker 8.0.3 disabled savegroup duration keeps incrementing

Hi Hrvoje,

that’s the crazy part about this situation.

I have already gone through those steps twice, unfortunately with the same result in both cases.

I suppose I could try it one more time, but include a server reboot at the end (instead of the NW services restart).

Thank you, Karel

0 Kudos
ble1
6 Indium

Re: Networker 8.0.3 disabled savegroup duration keeps incrementing

Sorry, you are right - I just checked original pdf in first email.  Then add following pre steps to my previous list:

- enable Default group (make sure it is empty)

- do savegrp -pv Default

- disable Default group

[...]

0 Kudos
karelkunz
1 Copper

Re: Networker 8.0.3 disabled savegroup duration keeps incrementing

Hi Hrvoje,

I added the pre-steps you’d recommended, stopped the NW services, renamed both the tmp folder and the jobsdb database and the associated database journal, and the restarted the NW services.

The outcome was the same; the Default group’s duration kept on increasing.

I then restarted the Networker server computer and again the outcome remained the same.

This is really baffling.

Regards, Karel

0 Kudos
bingo.1
4 Beryllium

Re: Networker 8.0.3 disabled savegroup duration keeps incrementing

Delete the Default group which is usually impossible:

  - locate the resource file (in /nsr/res/db which contains the 2 lines:

     type: nsr group

     name: Default

  - stop all NW daemons

  - delete the file

  - restart NW

A new resource file should automatically be created.

0 Kudos