Networker 8.2 - Linux - skipping mounted directories

I have 4 filesystems mounted in a directory called /nfs/:

  • /dev/sda1 > /nfs/1
  • /dev/sdb1 > /nfs/2
  • /dev/sdc1 > /nfs/3
  • /dev/sdd1 > /nfs/4

These directories are exported as network shares and I'm attempting to back them up, however, Networker is skipping these directories.I attempted making custom directives, using no directives and the issue is the same. I do have another directory under nfs that holds some application binaries and that gets backed up without an issue. It would seem Networker is skipping these because of the way they're mounted.

The only way to backup these folders is if i select the nfs sub-folders one at a time and perform a back up: so I check off / > nfs > 1 and nothing else it will backup that directory and its contents.

Thanks

Tags (2)
0 Kudos
3 Replies
Highlighted
ble1
6 Indium

Re: Networker 8.2 - Linux - skipping mounted directories

By default, NW will backup only local file systems.  NFS is not local file system as the name itself suggests

So, saveset All won't pick it up.

To pick it up, use All-nfs.  To pick up both local and nfs, in single client definitions instead of All use following two savesets:

All-mounts

All-nfs

Re: Networker 8.2 - Linux - skipping mounted directories

Thanks Hrvoje - but this is the NFS server. These are iscsi targets mounted as EXT4 filesystems and NW is still skipping them. They don't show up as separate filesystems like my other partitions do such as /, /boot, /var, etc.

I should mention these are mounted via the fstab file with UUIDs.

NFS clients would have these directories mounted as NFS volumes and it makes sense that NW would skip those mount points.

Where can I find these saveset options? I'd like to play with them to see if they resolve me issues.

Thanks

0 Kudos
ble1
6 Indium

Re: Networker 8.2 - Linux - skipping mounted directories

Try All-ext4

I'm not sure top of my head where these are documented, but I believe I have seen those in admin guide.

0 Kudos