Only Sql Transaction Log Backup

Hello,

I know this question asked several times and i read almost all discussions but no one gives exact answer to this.

Is there anyway to backup ONLY sql server transaction log (it is possible in ca arcserve backup). I dont want to backup database full or incr. i just want to backup transaction logs.

Tags (1)
0 Kudos
15 Replies
CarlosRojas
4 Beryllium

Re: Only Sql Transaction Log Backup

Hello,

Yes indeed, with NMSQL you can only backup the transaction log, but not with NMM 2.3

I would suggest you to take a look at NMSQL documentation.

Anyway you have to bear in mind that, in order to have incremental or differential backups you will ALWAYS need a full backup

For TLogs there is some specific options though, pretty clearly defined in NMSQL docs.

Note that NMM 2.3 only supports full backups, so only NMSQL would be your option here.

Thank you.

Carlos.

0 Kudos

Re: Only Sql Transaction Log Backup

Thanks for your help . Regarding the nmsql document i create the backup command like this " nsrsqlsv -s 34istemcnwbck -l incr -b SAPPOOL -R -H MSSQL:ABT " i have 8 gb tlogs in sql server and i expect that the backup only this 8 gb but the job runs 15 min. and backup 40gb data so it is not backing up only trans backups. Am i clear enough ? the command can not run as expected.

0 Kudos
CarlosRojas
4 Beryllium

Re: Only Sql Transaction Log Backup

Hi,

Remember that first backup will be always full.

Why are you using the -R and -H?

-R uses the NO_TRUNCATE option when backing up transaction logs, don't you want to truncate the logs?

-H uppercase -H uses the NORECOVERY option when backing up transaction logs. It leaves the database in Restoring state. Do you really want to leave the DB in that status?

You can check, once the backup completes, open NMSQL GUI and see what has been backed up.

Thank you.

Carlos.

0 Kudos

Re: Only Sql Transaction Log Backup

Yes you are right i dont need -R and i have to use -h not -H i am trying now.

0 Kudos
CarlosRojas
4 Beryllium

Re: Only Sql Transaction Log Backup

Hi,

the -h is used to skip specified DB, is not to skip DB and backup logs, so if you run -h DB_NAME that DB will be skipped in the backup, as well as its logs.

Thank you.

Carlos

0 Kudos

Re: Only Sql Transaction Log Backup

so what is the correct arrangement this is the last version of my backup command " nsrsqlsv -s 34istemcnwbck -l incr -b SAPPOOL -h MSSQL:ABT " and still backing up all database

0 Kudos
Highlighted
CarlosRojas
4 Beryllium

Re: Only Sql Transaction Log Backup

Hi,

If you run this command twice the first time should run full (DB+TLogs) and the second time should run incremental (Only TLogs).

If this doesn't work try the same from NetWorker server.

Command to run, for all DB's:

nsrsqlsv -s 34istemcnwbck -l incr -b SAPPOOL MSSQL:

If you want to exclude Model and Master DB's then run:

nsrsqlsv -s 34istemcnwbck -l incr -b SAPPOOL -h model -h master MSSQL:

The name of the DB you want to exclude is like that, no need to add MSSQL:DB_NAME

Thank you.

Carlos.

0 Kudos

Re: Only Sql Transaction Log Backup

ok here is the offical answer from emc networker engineer:

There is not such thing in Networker as transaction log backup

i am give up .

0 Kudos
CarlosRojas
4 Beryllium

Re: Only Sql Transaction Log Backup

Hi,

I don't agree with that answer, I'm sorry.

Incremental backups will backup ONLY the TLogs of SQL DB so, having this say I would suggest you to:

1.- Configure a client entry in NetWorker server for SQL client

2.- Configure a group, or include that client in a group with schedule full+Incrementals as you wish

3.- Run a backup (first one will be full) and then run a second one incremental level, or either check the box for the group configuration "Force Incremental". This backup should be incremental and backup ONLY the logs.

Running manual backup from command line can lead to this situation, NetWorker server not tracking the indexes hence all backups are being promoted to full.

Please try this option, it HAS TO WORK.

Hold on, how do you have the SQL DB configured? Is it Simple mode, full mode or bulk mode?

Please refer to the documentation for more information. You have to configure the DB in full mode.

Thank you.

Carlos.