RPC send operation failed; errno = Connection reset by peer

I am getting below error backup groups , from one of the linux and windows host

Error from Linux host

76677:save: RPC send operation failed; errno = Connection reset by peer

5203:save: save failed on /var/SYSLOG1/FWSM_S2S-VPN/

lost connection to server, exiting

sjeditb40605:/var/SYSLOG1/FWSM_S2S-VPN: retried 4 times.

Error from Windows host

39078:save: RPC error: RPC send operation failed; errno = An established connection was aborted by the software in your host machine.

5195:save: save failed on \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2133\win32app\Spectrum\mysql\data\reporting\outagetype...

74209:save: Quit signal received.

sjeditb50105.corp.sva.com:H:\: retried 1 times.

5195:save: save failed on \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy2133\win32app\Spectrum\mysql\data\reporting\outagetype.MYD

74209:save: Quit signal received.

sjeditb50105.corp.sva.com:H:\: retried 1 times.

Modified TCPIP parameter in registry, still issue persist

0 Kudos
4 Replies
TimQuan
4 Germanium

Re: RPC send operation failed; errno = Connection reset by peer

Verify the network connection between networker server and the problematic client is normal.

Suggest:

  1. Ping/nslookup/rpcinfo
  2. Use Hosts files
  3. Delete peer information https://community.emc.com/docs/DOC-20085
  4. Verify Short and long aliases in client resource in NMC

Henrik_Mueller
1 Copper

Re: RPC send operation failed; errno = Connection reset by peer

Which NetWorker version do you use?

When does this error happen (full / incr backup, heavy NW server load, ...)?

Currently we have the same error with multiple clients and from what I heared it could be a common error in v 8.0.

0 Kudos
bingo
4 Germanium

Re: RPC send operation failed; errno = Connection reset by peer

May i suggest you use the NW Health Check Tool (HCT), available from support.

0 Kudos
singhmridul
1 Nickel

Re: RPC send operation failed; errno = Connection reset by peer

Pls chk the following:

Group inactivity time-out. Ideally it should be set to 0.

Have a look for tcp chimney and if enabled, disable it and try the backup.

change the tcpkeepalive time from default of 2 hours to 15-30 mins.

0 Kudos