Brian91
2 Iron

Schedule Skips When It Should Run (And Runs When It Should Skip)

Hi everyone

We have a schedule called Full Last Friday of Month:

nsradmin> print type:nsr schedule;name:Full Last Friday of Month

                        type: NSR schedule;

                        name: Full Last Friday of Month;

                     comment: ;

                      period: Week;

                      action: skip skip skip skip skip skip skip;

                    override: Full last Friday every month;

The GUI calendar shows it is due to run today, today being 25th May (next Friday would be 1st June, not 32nd May!).

However, a group that uses that schedule did not run this morning.  Running it manually shows that the group is skipped.  It doesn't matter if the group has this schedule attached to it or just the clients within the group, the run today is skipped.  When I manually run backups that are due to run tonight, they are also skipped.

This schedule has run flawlessly since I created it about a year ago when I took this particular system over and it's worked flawlessly on other systems I've administered.

Also, the clients that have the schedule that includes the overrride of "Skip last Friday every month" were backed up today.

The only change was that we went from 7.5.2 to 7.6.3 - but that was in April and last month's full backups ran successfully on Friday 27th April.  I've cleared the override and reset it, but still the same.  In order to get it to run, I've had to create a new schedule:

nsradmin> print type:nsr schedule;name:TEST_Monthly

                        type: NSR schedule;

                        name: TEST_Monthly;

                     comment: ;

                      period: Week;

                      action: skip skip skip skip skip skip skip;

                    override: Full last Friday every month;

Spot the difference, apart from the name?  No, me neither.

This schedule has been attached to each client, however, out of nine clients in the group, only one actually backed up any data; the rest were skipped.  When attached at the group level, all clients in the group were skipped.  When removed (i.e. client-level schedule comes into effect), the same one client as before was backed up while the others were skipped.

The only way I seem to be able to get this schedule to work is by clearing the "Full last Friday every month" override and forcing a full override for today:

nsradmin> print type:nsr schedule;name:TEST_Monthly

                        type: NSR schedule;

                        name: TEST_Monthly;

                     comment: ;

                      period: Week;

                      action: skip skip skip skip skip skip skip;

                    override: full 5/25/2012;

Has anyone seen this before?

Thanks

B

Tags (3)
0 Kudos
5 Replies
Highlighted
coganb
3 Argentium

Re: Schedule Skips When It Should Run (And Runs When It Should Skip)

Hi B,

The word 'last' is not supported in this context which is why it's not working.  This is detailed in the Command Reference Guide:

http://powerlink.emc.com/km/live1/en_US/Offering_Technical/Technical_Documentation/300-011-695.pdf?

Look for the nsr_schedule command and the 'override' section where it lists that 'last' will not work.

-Bobby 

Brian91
2 Iron

Re: Schedule Skips When It Should Run (And Runs When It Should Skip)

Hi Bobby

Thanks for this and, as you say, the Command Reference Guide states it is not supported.  But that doesn't explain why it has worked before - last month with 7.6.3 and previous installations running 7.5.2, 7.4.2, 7.4 and even 7.2.2!

B

0 Kudos
Brian91
2 Iron

Re: Schedule Skips When It Should Run (And Runs When It Should Skip)

Update:

The backups that were due to run on the Last Friday of the month did not run.

The backups that were due to run on the Last Saturday of the month did run.  I think that this is a bug with NetWorker in that if the last day of the month is 6 days away, then it is incorrectly calculated.  Perhaps this is why, according to the Command Reference Guide and Bobby's post:

The use of "last" for number is not supported (for example, "last friday" cannot be used to refer to the last Friday of the month).

This situation will not arise again until January 2013, so rather than change all my schedules, I think I'll take a diary note and wait and see what happens.

B

0 Kudos
Brian91
2 Iron

Re: Schedule Skips When It Should Run (And Runs When It Should Skip)

Update:

Well, it's January 2013 and the last Friday of the month is 6 days away from the month end.  However, the backups that were due to run on the Last Friday of the month did run.

It's probably this inconsistent approach which is why it's not supported.  I think I'll get my schedules changed anyway to be the first Friday of the month.

B

0 Kudos
bingo.1
4 Tellurium

Re: Schedule Skips When It Should Run (And Runs When It Should Skip)

If you really want to insist on a 'last friday' schedule you may also use an external scheduler (Windows Task Scheduler) which starts an appropriate savegrp command (savegrp -l full -G group) that day.

Do not forget to set the group's autostart option to 'disabled'.

0 Kudos