lpamintuan
1 Nickel

Server Upgrade

I'm upgrading our backup server and I thought of installing the latest Red Hat O/S too which is Red Hat 6.1 and also due to the ext4 file system which they said a lot faster than ext3. Now I tried to install Networker v7.6.1-1 (64 bit) and getting a lot of failed dependencies error. I tried to install the missing packages and still not working. Anybody know if Red Hat 6 is compatible with the latest Networker version?

thanks in advance.

Tags (2)
0 Kudos
5 Replies
BGuevara
2 Iron

Re: Server Upgrade

Hi,

Yes, nw 7.6 is compatible with RH 6, not sure if is compatible with 6.1. You can see that in software compatibility guide.

Libraries needed to install prior to upgrade are specified in installation guide.

Regards.

0 Kudos
ble1
5 Iridium

Re: Server Upgrade

It should be, but can you show exactly what error do you get?  I usually install the package via yum and yum will take care of all dependencies out there.

0 Kudos
lpamintuan
1 Nickel

Re: Server Upgrade

here is the error message:

/bin/ksh is needed by lgtoclnt-7.6.1.3-1.x86_64
libcap.so.1()(64bit) is needed by lgtoclnt-7.6.1.3-1.x86_64
/bin/ksh is needed by lgtoserv-7.6.1.3-1.x86_64
/bin/ksh is needed by lgtonmc-7.6.1-1.i686
libuuid.so.1 is needed by lgtonmc-7.6.1-1.i686

when I try to install one of the missing package:

[root@backupserv linux_x86_64]# yum install libcap.so.1
Loaded plugins: product-id, refresh-packagekit, rhnplugin, subscription-manager
Updating Red Hat repositories.
Setting up Install Process
Package compat-libcap1-1.10-1.i686 already installed and latest version
Nothing to do

I tried --nodeps, it worked, but cannot initialize lgtonmc because it is looking for one of the missing packages.

0 Kudos
Highlighted
ble1
5 Iridium

Re: Server Upgrade

CG does not list RH6 for NMC part.  That could be a typo or indication

ksh is easy... in my case yum states:

ksh-20100202-1.el5.x86_64 : The Original ATT Korn Shell

Repo        : installed
Matched from:
Other       : Provides-match: ksh

libcap I use is:

libcap-1.10-26.i386 : Library for getting and setting POSIX.1e capabilities

libuuid.so.1 I use is:

e2fsprogs-libs-1.39-23.el5.i386 : Ext2/3 filesystem-specific static libraries and headers

Difference is that you run v6x while I run 5.5.  I also run 7.5.4.x while you run 7.6.1.3 (7.6.1.7 being latest I believe now).  Not sure if NMC binaries have changed, but in my case I see:

file gstd

gstd: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.2.5, dynamically linked (uses shared libs), for GNU/Linux 2.2.5, stripped

libcap note by system indicates you might have 32bit version in path, but not 64bit and then it would be just a matter of updating lib paths.  I think it should be easy to fix it, but we do not use RH6 as there is no reason for it so I do not have test system to play around.  I believe lgtonmc is looking for ksh and libuuid.so.1 as indicated.  Try to add those and NMC should be ok then.

lpamintuan
1 Nickel

Re: Server Upgrade

I talked to EMC support and indeed they indicated that Networker is not supported with Red Hat v6.1 yet and also  they advised me to dowload the latest Networker fron their FTP site. It might work or fix some bugs, but thats it.

Thanks a lot for all the replies.

0 Kudos