shorwitz
1 Nickel

Unable to find record for job 395159 during an attempt to send message to i

I saw the other thread with a similar topic, but since its marked as solved, I figured I should start a new topic. Is it safe to assume, based on what was said in that other thread from earlier today that jobsdb is having trouble tracking jobs? I see how to change the retention period and jobsdb size, but I do not know what changes would be sensible for the size and retention period.

Are there any guidelines to help me set these parameters for my site? I run NetWorker 7.4.1 under Solaris 10 sparc on a Sun T2000 with one Red Hat Linux storage node and a Sun X4500 storage node (with Solaris 10).

Thank you
Tags (1)
0 Kudos
5 Replies
Highlighted
fjsacristan
2 Iron

Re: Unable to find record for job 395159 during an attempt to send message to i

Hi Stan,

You can change size and retention in server properties, where you will can see there size and retention settings for jobdb entries.

This change did not solved me the issue.

You can change this value when there are not backpus running.

My solution was:

- Stop NetWorker Services on Backup Server.
- Rename /nsr/tmp and /nsr/res/jobsdb
- Start NetWorker Services on Backup Server.

In this way, these messages will dissapear.

Regards.

Inma Bernabe.
ble1
5 Iridium

Re: Unable to find record for job 395159 during an attempt to send message

Stan, there are some "mandatory" patches for 7.4.1 involving nsrjobdb management. Removing existing db will fix it for certain time, trimming down db properties will keep it safe for a bit longer and then it is either patch or 7.4SP2 once that is out.
shorwitz
1 Nickel

Re: Unable to find record for job 395159 during an attempt to send message

Please elorate on what these patches are? What do they fix? Also, it seems that the error message stopped appearing in the daemon.raw file when I checked on Friday morning. I am inclined to wait for 7.4 SP2, but I would like to know about these mandatory patches because I have had some cases open with EMC for months since I upgraded from 7.2.1 to 7.4 and no one on the EMC side has suggested I install any patches.
0 Kudos
ble1
5 Iridium

Re: Unable to find record for job 395159 during an attempt to send message

I said "mandatory" - quotes with purpose :)

I believe the issue you reported here should be addressed by trimmed db. If EMC recommended no patches then I assume those were not identified to fit your site/configuration. Nevertheless, in the meantime 7.3SP4 has been released which addresses some data loss issues present across all current versions (7.2.x, 7.3.x and 7.4.x). Along with that release patches for all affected current releases were given out too. You probably would like to see that applied at your site.
0 Kudos
shorwitz
1 Nickel

Re: Unable to find record for job 395159 during an attempt to send message

Thank you. I will ask EMC about these patches.
0 Kudos