Highlighted
kmkramer25
2 Iron

VADP client failure

We have try most options and can't figure out why this is trying to use an IPv6 contact method for the client.

Here is the setup

proxy host - serverA

setup in the Virtualization option - expanding all of this shows all our VM servers/hosts

serverA client setup

VADP_MAX_BACKOFF_TIME=10

VADP_HOST=serverA.domain.com

VADP_BACKUPROOT=c:\mnt

VADP_MAX_RETRIES=0

VM client 1

name client1 - DNS resolvable

virtual client checked

physical host - esxsrv1.domain.com

no directives

saveset set to *FULL*

Apps & Modules

VADP_VM_NAME=client1

VADP_HYPERVISOR=serverA.domain.com

VMWare proxy host checked and set to serverA.domain.com(VADP)

this was all done within the Virtualization wizard

we get this when running the group that has these 2 clients

* client1:*FULL* savegrp: suppressed 18 lines of output.

* client1:*FULL* Max backoff time        : 10

* client1:*FULL* VDDK Install Directory: C:\Program Files\Legato\nsr\plugins\VDDK.

* client1:*FULL* VADP VM-TMP Directory Location: c:\mnt\client1\client1\client1-tmp\letters\1.

* client1:*FULL* Temporary Directory for VM created.

* client1:*FULL* VADP TMP Directory Location: c:\mnt\client1\client1\tmp.

* client1:*FULL* Temporary Directory for VADP created.

* client1:*FULL* Temporary vmMntLoc Directory for VADP created.

* client1:*FULL* 83065:nsrvadp_save: The following internal error occurred: Unable to initialize and log into VIM Server: 'https://fe80::d5b2:4e51:8b4b:df99:443/sdk' as user: 'administrator'.  Details: 'SOAP FAULT (v1.1) The requested name is valid, but no data of the requested type was found.  [getaddrinfo failed in tcp_connect()]'.

* client1:*FULL* 80998:nsrvadp_save: Failed to Initialise LibVADP Context.

* client1:*FULL* Temporary directory 'c:\mnt\client1' for VADP deleted.

The proxy host "serverA" backs up no problem. I can't find any reference to this error anywhere.

0 Kudos
6 Replies
Bebo2k
3 Zinc

Re: VADP client failure

Hi kmkramer25,

VADP does not support IPv6. If vCenter is installed in a Windows 2008 system with IPv6 enabled  (IPv6 is enabled by default) and the same system is also used as the VADP proxy, VADP backups will hang and fail.

Ensure that IPv6 is disabled on the following:

• vCenter

• ESX/ESXi

• VADP-Proxy

Note: ESX/ESXi above refers to the actual host system and not the Virtual Machines to be backed up.


Disable IPv6 using Network Connections in the Control Panel, and then add an IPv4 entry like the following to the hosts file on the system where vCenter is installed:

<IPv4 address>     <vCenter FQDN>    <vCenter hostname>


After this entry has been added, run the following command in the VADP proxy host to verify that the IPv4 address is being resolved:

C:\Users\Administrator>ping  <vCenter hostname>

Then make sure you configured the vCenter server name correctly in the Endpoint attribute of NSRhypervisor field as the following:

http://server_hostname /sdk

Where server_hostname is the FQDN name of the vCenter host and as no port has been specified , the default port (443) will be used.

Thanks,

Ahmed Bahaa

0 Kudos
kmkramer25
2 Iron

Re: VADP client failure

We have gone through this again.

Here is how the following map out from my post above

• vCenter - serverA.domain.com

• ESX/ESXi - esxsrv1.domain.com

• VADP-Proxy - serverA.domain.com

we have gotten up to this point in your post

Then make sure you configured the vCenter server name correctly in the Endpoint attribute of NSRhypervisor field as the following:

http://server_hostname /sdk

Where server_hostname is the FQDN name of the vCenter host and as no port has been specified , the default port (443) will be used.

The page does not fail and redirects to https://, but does not display anything. We kept going and recreated the VM host as a client in Networker using the Virtualization wizard tool.

Now we get this on the VM client backup.

* client1:*FULL* savegrp: suppressed 23 lines of output.

* client1:*FULL* Temporary Directory for VADP created.

* client1:*FULL* Temporary vmMntLoc Directory for VADP created.

* client1:*FULL* Performing the backup via the Virtual Center.

* client1:*FULL* Application information attribute VADP_VM_NAME for client client1 is set to "client1".

* client1:*FULL* Trying to connect to the VM using VM name 'client1'.

* client1:*FULL* Performing a FULL Image level backup.

* client1:*FULL* Creating snapshot for client1.

* client1:*FULL* Creating snapshot for 'vm-118' ...

* client1:*FULL* 74854:nsrvadp_save: The following VMware related error occured: Unable to create snapshot '_VADP-BACKUP_' for VM: vm-118.  Details: 'An error occurred for task 'CreateSnapshot_Task'.  Details: Unable to communicate with the remote host, since it is disconnected.'.

* client1:*FULL* 80405:nsrvadp_save: Could not create Snapshot for VM 'client1'.

* client1:*FULL* Temporary directory 'c:\mnt\client1' for VADP deleted.


0 Kudos
Bebo2k
3 Zinc

Re: VADP client failure

Hi kmkramer25,


First of all make sure that you add the VADP_VM_NAME variable in the Application Information attribute of each NetWorker virtual Client resource Correctly. The variable format is entered as VADP_VM_NAME=vm1 

Where vm1 is the display name of the VM used in the vCenter


VADP_VM_NAME is case-sensitive. For example, if the VM host name is upper-case (such as SuSe11-X86), the value of VADP_VM_NAME must be set to SuSe11-X86.


For the “Unable to communicate with the remote host, since it is disconnected”  error message, you have to verify that there is no communication, or DNS issue between the Backup Server, Storage Node, ESX Server, or Virtual Center server.

I had this issue before and I solved by deleting the Virtual Machine from inventory (right click on the VM and select “Remove from Inventory”). Do not delete from disk  Then, re-add the VM by browsing the datastore holding that VM, right clicking on the VMX file and selecting “Add to Inventory”.

Hope that helps to solve the issue.

Thanks,

Ahmed Bahaa

0 Kudos
Bebo2k
3 Zinc

Re: VADP client failure

If my thoughts did not solve the issue , please have a look as well on the following Powerlink article:

https://solutions.emc.com/emcsolutionview.asp?id=esg121746

Thanks,

Ahmed Bahaa

0 Kudos
Bebo2k
3 Zinc

Re: VADP client failure

Hi kmkramer25,

How is the VADP backup issue ? is it solved or the problem still occured with the same error messages ?

Thanks,

Ahmed Bahaa

0 Kudos
kmkramer25
2 Iron

Re: VADP client failure

The problem appears to be the our vpshere license expired. We are working on clearing that up before proceeding. I'll update again after that piece is resolved.

0 Kudos