Highlighted
Mizicke52731
1 Nickel

Re: VSS System Failed w2k8 Access denied

Thank you, this has resolved an issue I was having with a Windows Server 2008 R2 Client with IIS and VSS.  I had tried save -a '"ignore-all-missing-system-files=yes"' and NSR_IGNORE_MISSING_SYSTEM_FILES=yes, but your suggestion is what finally worked for me.

This is the issue I was experiencing:

5388:save: Failure status of writer IIS Metabase Writer - STABLE

VSS OTHER: ERROR: VSS failed to process snapshot: Writer status is not available for one or more writers.  A writer may have reached the limit to the number of available backup-restore session states. (VSS error 0x80042409)

Following ruhailv's suggestion resolved the issue:

1.       Stop networker (make sure that nsrexecd is killed by double checking in the task manager)

2.       Stop VSS service if its running

3.       Restart WMI performance adapter service

4.       Restart com+ event system (and all other dependent services)

5.       Delete all the files under /nsr/tmp (not the folder, but the files inside it)

6.       Put vss to manual and start it

7.       start networker (make sure that nsrexecd is running by double checking in the task manager)

0 Kudos