Highlighted
Shekar_001
1 Copper

VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Hi,

I have been facing a issue since I upgraded my DD OS from 5.4.0.8 to 5.4.2.1

We do have many dedicated Linux storage nodes (Virtual drives from DD), When the tapes get mounted on these dedicated devices, they are immediately marked as "FULL" without any data getting written on to the tape.

We do also have Windows storage node for which we had assigned Virtual drives from the DD too, But I did not face any issues with the tapes getting mounted on the Windows storage node.

Version information :

Networker Server, Client - 8.0.1

Data Domain model : DD660

DD OS : 5.4.2.1

Networker Server OS : Windows 2008 R2

Networker client OS : OEL LINUX 5.7 

Appreciate your help

Thanks in advance.

0 Kudos
8 Replies
ble1
5 Iridium

Re: VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Prior to get marked full, there should be an error message as to why it is marked full.  Did you check that one?

0 Kudos
Shekar_001
1 Copper

Re: VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Yes, Below is the error in daemon log

(Warning) <VolumeID> marked full prematurely.writing: Input/output error, at file 4 record 3410

Verify possible error on the device <Device name>

Before the DD OS upgrade, the same devices were working fine.

0 Kudos
ble1
5 Iridium

Re: VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Test the position:

a) load the tape into the drive on Linux node (preferably same device) using non NW method (for example use sjimm)

b) test positiong (for example mt -f <device> rewind; mt -f <device> fsf 4; mt -f <device> fsr 3410)

c) if you get IO error, good

d) unmount the tape and load it into Windows drive and do the same test

e) do you get IO error there?

From what you said so far, it looks more like driver issue of some kind, but without any details it could be anything.  Do you really run 8.0.1? What patch level?  Given that you updated DDOS, you might think of updating backup application too.

snthr
1 Nickel

Re: VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Hi,

I had the same situation. After upgrade tapes were pre-maturely marked as full. Before the upgrade everything was working OK.

I have open the SR with the EMC and they concluded that we are using unsupported FC HBA on NW server.

Check if your FC HBA is on support list for DD.

BR,

Bojan

Shekar_001
1 Copper

Re: VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Hi Bojan,

Thanks for the inputs, Did that resolve your issue ?

Can you please share the Supported FC HBA list for DD

0 Kudos
Shekar_001
1 Copper

Re: VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Hi Hrvoje,

Thanks for your inputs too. I will share with you the result soon.

0 Kudos
Shekar_001
1 Copper

Re: VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Hi Bojan,

EMC concluded the same for me too..Any idea what resolution can be done to overcome this issue.

Please help.

0 Kudos
snthr
1 Nickel

Re: VTL Tapes pre-maturely marked as "FULL" in Networker after DD OS Upgrade to 5.4.2.1

Hi Shekar,

I have configured DDboost over FC on that same FC HBA and it is working fine.

But EMC gave me a hint to try to enable FCP2-retry setting on HBA, but I haven't try that yet

BR,

Bojan

0 Kudos