2 Bronze

Virtual Driver - Save problem

Hi

we got a Server with three drivers. Tow of them are local drivers and one of the driver is a "virtual driver". The backup get failed.

We got the message:

7184:savefs: nothing to save

savefs servername.dom.com: failed.

--- Job Indications ---

servername.dom.com:savefs: retried 1 times.

On the Server we use Networker 9.1.1.3 and Windows Server 2016.

If somone can help me?

0 Kudos
11 Replies
4 Ruthenium

Re: Virtual Driver - Save problem

I assume you are talking about "drives" not "drivers".

Before you do anything else please answer the following questions:

  -  Does a back wor at all? - just run "save C:\temp" to test

If successful:

  -  Do the preconfigured backups of the server work (Policy: Server Protection work)

If yes, your configuration seems to be wrong. So please provide more info to assist you.

0 Kudos
2 Bronze

Re: Virtual Driver - Save problem

Hi Bingo,

you are right i mean drives (sorry for my bad english )

I can save C:\temp and the Server Protection works fine too.

What infos do you need to assist me?

0 Kudos
4 Ruthenium

Re: Virtual Driver - Save problem

So the backup of a local disk is not a problem.

The next step would be to run a manual backup of the network disk.

Please run the following command:   save [-b <pool>] -L -o "vss:*=off" \\<server>\<path>

to see if this works

If yes - fine.

But please state the exact error message to better assist you.

0 Kudos
3 Argentum

Re: Virtual Driver - Save problem

What do you mean by "virtual driver"? 


Please show what this looks like...  From Windows Explore, how would you access this drive?


From command line, how would you change directory to this drive?

0 Kudos
2 Bronze

Re: Virtual Driver - Save problem

Hi Wallace,

here is a screen from my Windows Explorer:

Unbenannt.PNG.png

I cant backup volume E: it is a virtual drive.


bingo:

With your command i can save the virtual drive, but if i start it on the "NetWorker Management Consol" it failed


3817:save: Using NETWorkerSvr.dom.lan as server

129292:save: Successfully established Client direct save session for save-set ID '1351349813' (SERVER.dom.lan:\\SERVER.dom.lan\E$) with Data Domain volume 'data1.001'.

\\SERVER.dom.lan\E$\$RECYCLE.BIN\S-1-5-21-790525478-1085031214-839522115-500\desktop.ini

\\SERVER.dom.lan\E$\$RECYCLE.BIN\S-1-5-21-790525478-1085031214-839522115-500\

\\SERVER.dom.lan\E$\$RECYCLE.BIN\

\\SERVER.dom.lan\E$\5462_boot.iso

\\SERVER.dom.lan\E$\afasfas.txt

\\SERVER.dom.lan\E$\ibm_fw_imm_yuoo57h_windows_32-64.exe

\\SERVER.dom.lan\E$\ibm_fw_uefi_d6e162a-1.20_windows_32-64.exe

\\SERVER.dom.lan\E$\sdasfasf.txt

\\SERVER.dom.lan\E$\System Volume Information\WPSettings.dat

\\SERVER.dom.lan\E$\System Volume Information\

\\SERVER.dom.lan\E$\

/

save: \\SERVER.dom.lan\E$  1569 MB 00:00:22     12 files

7167:save: save completion time: 20.02.2018 11:19:49

94694:save: The backup of save set '\\SERVER.dom.lan\E$' succeeded.

.

0 Kudos
4 Beryllium

Re: Re: Virtual Driver - Save problem

Umut47

  Well, generally this is called a network mount point. You can trying using the backup command as save -xL That should help get the mounted network share backed up.

HTH,
For NetWorker related content - https://www.youtube.com/channel/UC4JLsVyXMyjbQ4i1NaJj5IQ

0 Kudos
2 Bronze

Re: Virtual Driver - Save problem

Hi CrazyRov

i typ it as a network mount because bingo give me a command with a network mount (save [-b <pool>] -L -o "vss:*=off" \\<server>\<path>).

On the pic you can see its a virtual drive and not a network mount.

0 Kudos
3 Argentum

Re: Virtual Driver - Save problem

Please explain why you say E: is a virtual drive.  From your screenshot, I do not see what the difference between 😧 and E: drives.  What is "virtual"  ?

Back to the original problem:  are you still getting the error "savefs: nothing to save"?  Is the client's saveset field set to "All"?

0 Kudos
2 Bronze

Re: Virtual Driver - Save problem

Hi Wallace,

i created in Windows Server 2016 a virtual hard disk drive ( https://en.wikipedia.org/wiki/VHD_(file_format) ) and drive E: is for me a virtual drive.


If i set the saveset field to "All", i can save all drivers (C: D:) but not E:


1.PNG.png


2..PNG.png


3..PNG.png


If i try to Save it solo (E:) i get the same error "savefs: nothing to save"

5..PNG.png


4..PNG.png


If i am on the computer and typing on cmd "save -L E:\" it works

6..PNG.png

7..PNG.png

I dont unterstand why i cant run it solo or as a all saveset, but it work if i typeing it in cmd...

Sorry for so much images, but i think its easy to show you guys it.





0 Kudos