Highlighted
BACKUP_S
1 Copper

/etc/init.d/networker start nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

Jump to solution

Hi  ALL,

I am getting this error on  RHEL  linux  5.4

IPv6  is disabled , and  etntries  are  in  place  but still getting error . can  you please advise

# Do not remove the following line, or various programs

# that require network functionality will fail.

127.0.0.1       localhost

::1             localhost6.localdomain6 localhost6

error as below

/etc/init.d/networker   start

nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

0 Kudos
1 Solution

Accepted Solutions
BACKUP_S
1 Copper

Re: /etc/init.d/networker start nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

Jump to solution

Hi  Hrvoje/Adam,

Thanks  all  for support and  suggestions...as mentioned  above all entries where  added .

Issue  is with  my nsswitch.conf  file   on linux . It is  not there  i.e it was renamed to nsswitch,conf_old.

So when ever I start services it is not able to get parameters   and getting failed ,s o finally I had renamed them and  services  started ....

Thanks  again for Kind support ..

Bhanu.K

0 Kudos
6 Replies
ble1
6 Indium

Re: /etc/init.d/networker start nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

Jump to solution

IPv6 is probably not disabled - you can verify that from ifconfig -a where you will find ::1 entry most likely.

Your hosts entry should be something like:

127.0.0.1localhost.localdomain localhost
::1localhost6.localdomain6 localhost6
0 Kudos
mradamk
3 Argentium

Re: /etc/init.d/networker start nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

Jump to solution

Try changing the host file entry to the following;

::1 localhost loopback

This is the value I have and it was inserted automatically by Netwroker when installing the agent.

0 Kudos
ble1
6 Indium

Re: /etc/init.d/networker start nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

Jump to solution

NetWorker modifies /etc/hosts?

Adam Kirkpatrick wrote:

This is the value I have and it was inserted automatically by Netwroker when installing the agent.

0 Kudos
mradamk
3 Argentium

Re: /etc/init.d/networker start nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

Jump to solution

I believe so, I’m pretty sure I didn’t add it myself.

0 Kudos
ble1
6 Indium

Re: /etc/init.d/networker start nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

Jump to solution

I didn't see any release of NW doing that so far - so it might be done by either system or some other OS admin.

0 Kudos
BACKUP_S
1 Copper

Re: /etc/init.d/networker start nsrexecd: Failed to resolve the IPv6 localhost address ::1. Please verify an entry for the IPv6 localhost address exists in your /etc/hosts file.

Jump to solution

Hi  Hrvoje/Adam,

Thanks  all  for support and  suggestions...as mentioned  above all entries where  added .

Issue  is with  my nsswitch.conf  file   on linux . It is  not there  i.e it was renamed to nsswitch,conf_old.

So when ever I start services it is not able to get parameters   and getting failed ,s o finally I had renamed them and  services  started ....

Thanks  again for Kind support ..

Bhanu.K

0 Kudos