teri.e36
2 Bronze

nsrexec: authtype error on Windows XP client

I have a Windows XP client running NW 7.3.3 (we have also tried 7.3.2, which is what most of our other clients use; same results). This is a new client that has never backed up properly using scheduled backups. It *does* back up properly if I run the save manually from the client.

Hostname resolution works properly from client to server and from server to client, both FQDN and un-FQDN are at the bottom of the servers file on the client. There are no obvious errors in the daemon.log except "nsrexec: authtype". Restarting the Networker service (either using the GUI or from the command prompt) on the client does not help. Below is the output of running savegrp from the server:

client.domain.com:All level=incr
02/05/08 13:24:25 savegrp: Run up to 50 clients in parallel
02/05/08 13:24:25 savegrp: client.domain.com:probe started
savefs -s server.domain.com -c client.domain.com -g Laptops -p -l full -R -v
02/05/08 13:24:26 savegrp: client.domain.com:probe succeeded.
* client.domain.com:All rcmd client.domain.com, user root: `savefs -s server.domain.com -c client.domain.com -g Laptops -p -l full -R -v'
* client.domain.com:All nsrexec: authtype
02/05/08 13:24:26 savegrp: client.domain.com:probe will retry 1 more time(s)
02/05/08 13:24:26 savegrp: client.domain.com:probe started
savefs -s server.domain.com -c client.domain.com -g Laptops -p -l full -R -v
02/05/08 13:24:26 savegrp: client.domain.com:probe succeeded.
* client.domain.com:All 1 retry attempted
* client.domain.com:All rcmd client.domain.com, user root: `savefs -s server.domain.com -c client.domain.com -g Laptops -p -l full -R -v'
* client.domain.com:All nsrexec: authtype
02/05/08 13:24:26 savegrp: client.domain.com:probe will retry 0 more time(s)
02/05/08 13:24:26 savegrp: client.domain.com:index started
save -s server.domain.com -S -g Laptops -LL -f - -m server.domain.com -V -t 1202142662 -l 9 -LL -W 78 -N index:20ae5c37-00000004-476a73da-476a73d9-0dd20000-ac150721 /nsr/index/client.domain.com
02/05/08 13:24:27 savegrp: client.domain.com:index succeeded.
* client.domain.com:index rcmd localhost, user root: `save -s server.domain.com -S -g Laptops -LL -f - -m server.domain.com -V -t 1202142662 -l 9 -LL -W 78 -N index:20ae5c37-00000004-476a73da-476a73d9-0dd20000-ac150721 /nsr/index/client.domain.com'
* client.domain.com:index save: Saving files modified since Mon Feb 4 11:31:02 2008.
* client.domain.com:index
server.domain.com: index:client.domain.com level=9, 0 KB 00:00:01 0 files
02/05/08 13:24:27 savegrp: nsrim run recently, skipping

Any suggestions on how to fix this would be appreciated.
0 Kudos
5 Replies
ble1
7 Thorium

Re: nsrexec: authtype error on Windows XP client

As you can see, savefs fails and seems to suggest you can't talk or get an answer from client. This may suggest your XP has firewall configured blocking communication back to server/client.

Try following from server:
echo print | nsradmin -p 390113 -i - -s client.domain.com

and

rpcinfo -p client.domain.com
0 Kudos
teri.e36
2 Bronze

Re: nsrexec: authtype error on Windows XP client

Output of "echo print | nsradmin -p 390113 -i - -s client.domain.com":

type: NSRLA;
name: client.domain.com;
NW instance info operations: ;
NW instance info file: ;
installed products: NetWorker 7.3.3.Build.510;
version: "EMC NetWorker 7.3.3.Build.510 ";
servers: server.domain.com;
auth methods: "0.0.0.0/0,nsrauth/oldauth";
administrator: \
"group=Administrators,host=client.domain.com",
"group=Administrators,host=localhost",
"isroot,host=server.domain.com";
kernel arch: INTEL_PENTIUM;
machine type: desktop;
OS: Windows XP 5.1;
NetWorker version: 7.3.3.Build.510;
client OS type: Windows NT Workstation on Intel;
CPUs: 2;
MB used: 20465;
IP address: 172.21.7.3;


Output of "rpcinfo -p client.domain.com":
program vers proto port
100000 2 tcp 7938 portmapper
100000 2 udp 7938 portmapper
390436 1 tcp 8190
390435 1 tcp 8371
390113 1 tcp 7937 nsrexec
0 Kudos
ble1
7 Thorium

Re: nsrexec: authtype error on Windows XP client

Make sure your client is called client.domain.com. Then check if nslookup on it will give you 172.21.7.3 and the other way around. Check also short name and make sure it is on alias list of client.

As it works in one direction, do start backup again and go to client. Check with task manager if you see thw save or savefs. In case you have VSS licenses, try to force NW not to use it.
0 Kudos
teri.e36
2 Bronze

Re: nsrexec: authtype error on Windows XP client

The client hostname is correct, both short and long versions, and nslookup works both ways, using IP or using hostname. Both short and long hostnames are listed in the alias field of the client config in NW. I also added the hostname and IPs to the hosts file, just to cover all the bases.

We don't have any VSS licenses, and I'm not sure how to force NW not to use them, but since we don't have any that shouldn't matter, right?

The client is currently offline; I will test another backup and check Task Manager when it's back (likely tomorrow).
0 Kudos
ble1
7 Thorium

Re: nsrexec: authtype error on Windows XP client

Yes, VSS in that case should not be used. I suspect it hangs at savefs part... in case you use saveset All you would see in group details contacting clients and All not being resolved to savesets on that machine. One thing to try also is to install backup server on that client (eval), create disk device and try same savset backup.. if that works it means issue is not on client but rather on server or path from clint to server (eg. network routing, firewall, some problematic NIC parameter like oflloading, etc).
0 Kudos